Closed Bug 606983 Opened 12 years ago Closed 12 years ago

[D2D] Verify surface devices match

Categories

(Core :: Graphics, defect)

x86
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Tracking Status
blocking2.0 --- beta7+

People

(Reporter: bas.schouten, Assigned: bas.schouten)

References

Details

Attachments

(1 file)

Since our new fallback logic for D3D10 layers it's possible for a new device to be used after a driver reset. We're currently continuing to draw however we're trying to use cached bitmaps from the old device, this doesn't work. We should not use the cached bitmaps if they don't belong to the right device.

This patch simply tosses the cached bitmaps, this is not the best thing ever if actually using multiple devices simultaneously but we don't do that. To support that situation we should use a key-per-device for storing the user-data but I don't think it's worth adding that complexity to the code at this point. This is the simplest solution for now I believe.
Attachment #485743 - Flags: review?(jmuizelaar)
Comment on attachment 485743 [details] [diff] [review]
Check if device matches

sent comments on IRC
Attachment #485743 - Flags: review?(jmuizelaar) → review+
Attachment #485743 - Flags: approval2.0?
blocking2.0: --- → beta7+
Attachment #485743 - Flags: approval2.0?
http://hg.mozilla.org/mozilla-central/rev/2f456d0310fa
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Duplicate of this bug: 607638
You need to log in before you can comment on or make changes to this bug.