If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Segfault (not sure why)

VERIFIED DUPLICATE of bug 4225

Status

()

Core
Layout
P3
critical
VERIFIED DUPLICATE of bug 4225
19 years ago
19 years ago

People

(Reporter: evand, Assigned: Chris McAfee)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
Occasionally, Apprunner just crashes. I find that I can repro the bug every time
on the page I listed in the URL: field. I get this error from the command line:

Error loading URL http://home.netscape.com/bookmark/4_06/gtesuperpages.html
.//run-mozilla.sh: line 35:  5084 Segmentation fault      $prog ${1+"$@"}

There are other pages on which I get this error (with the exception of the
"Error loading URL" part which is obviously changed for whatever page is
crashing Mozilla). The 5084 Segfault is constant, however.
(Reporter)

Updated

19 years ago
Component: other → Apprunner
(Reporter)

Comment 1

19 years ago
Hmm. Apparently my other comments didn't get in here.

Running Apprunner on M5, various pages cause a segfault. The output to the
command line is as follows:

Error loading URL http://home.netscape.com/bookmark/4_06/gtesuperpages.html
.//run-mozilla.sh: line 35:  5135 Segmentation fault      $prog ${1+"$@"}

As you can see, the error occurs on
http://home.netscape.com/bookmark/4_06/gtesuperpages.html, but other pages can
cause the segfault as well. I'm not sure what on the page is causing the crash,
but since that page appears to be a redirect page, it may be code in the GTE
SuperPages site that is causing the segfault, Unfortunately, there is no
indication either visually or on the command line output as to where the site is
going. Apprunner reports via the command line (above) that the error is in the
redirect page (gtesuperpages.html) and not on the actual site. Could a META tag
be the culprit?
(Reporter)

Updated

19 years ago
Severity: major → critical

Updated

19 years ago
Assignee: chofmann → rickg
Component: Apprunner → Layout
QA Contact: 3853 → 4144

Updated

19 years ago
Assignee: rickg → ramiro

Comment 2

19 years ago
Ramiro -- this looks like the same problem I sent you earlier.

Comment 3

19 years ago
i just tried this (it redirects to http://superpages.gte.org) and it seems to
work on the latest viewer build (may 14)

Updated

19 years ago
Assignee: ramiro → mcafee

Comment 4

19 years ago
ah, it works in viewer and crashes in apprunner.

mcafee, the stack trace looks just like the timer bug you have.  You can mark
this bug a dup of that.

thanks

reassigning to mcafee
(Assignee)

Updated

19 years ago
Target Milestone: M6
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 5

19 years ago
worksforme, going on ramiro's hint that this is a dup of 4225, the
timer bug.


*** This bug has been marked as a duplicate of 4225 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 6

19 years ago
Agreed. This is a duplicate of 4225.
You need to log in before you can comment on or make changes to this bug.