Closed Bug 607186 Opened 12 years ago Closed 11 years ago

Firefox hangs downloading when opening a new window after original window closed. window title contains (Not Responding)

Categories

(Firefox :: General, defect)

3.6 Branch
x86_64
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: ajlee322, Unassigned)

References

Details

(Keywords: hang, perf, Whiteboard: [testday-20120413])

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.11) Gecko/20101012 Firefox/3.6.11
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.11) Gecko/20101012 Firefox/3.6.11

Firefox hangs and slows down to a halt while still downloading upon opening a new window.  The new window is what hangs but this is while files are downloading still and the original window that was used was closed because it was no longer needed for the download. The file being downloaded is a video file and is quite large. The file being downloaded seems to not matter where it is downloaded from whether a third party site like Megaupload or an FTP server. The download also slows down from going quick to a lower amount upon closing the original Firefox window as well. The only way to fix this is to wait until the download completes before opening a new window so that it is back to normal or to close both the newly window as well as the download window. Another thing noticed by opening the task manager is that Firefox when downloading and a new window opens during this problem the CPU usage is extremely high.

Reproducible: Always

Steps to Reproduce:
1.Open Firefox and begin downloading a large file usually a media file like a video since that is what I have experienced it with
2.Close that Firefox window while the file is still downloading
3.Open a new Firefox window while the file is still downloading
Actual Results:  
The new Firefox window slows down and hangs as well as the download window and proceeds to Not Responding in the Windows Task Manager.

Expected Results:  
The software should instead of acted like the original window while downloading and continue at the normal speed loading the contents of the website instead of slowing down and halting. Causing Firefox to go to the state of Not Responding in Windows Task Manager.

Using the theme LavaFox V1 V1.2.2 I have not tried this with the default theme however this problem never occurred with this theme before and didn't start occurring until Firefox Version 3.6.10 and has persisted into version 3.6.11
Severity: critical → major
Keywords: hang
Version: unspecified → 3.6 Branch
Please create a new profile and test there. http://support.mozilla.com/en-US/kb/managing+profiles
(In reply to comment #1)
> Please create a new profile and test there.
> http://support.mozilla.com/en-US/kb/managing+profiles

Created a new profile and its still having the issue.
in windows task manager, is 90+% of the cpu usage kernel time?
 (the red line, not the green)

This is not a permanent hang, correct?  Just a "hung" for a long time.
Keywords: perf
Summary: Firefox hangs downloading when opening a new window after original window closed → Firefox hangs downloading when opening a new window after original window closed. window title contains (Not Responding)
ajlee3, This is not a permanent hang, correct?  

please retest with version 4, and please provide a testcase URL
Whiteboard: [closeme 2011-05-01]
Firefox 4 on Windows 7 64bit showing bug 607186
I modified the images in order to hide personal information and megaupload links. No modification were made to firefox and task manager windows (except links,favourite links and red arrows to indicate important things)

ff1-mod.png - everything runs smoothly, cpu usage is minimum 
ff3-mod.png - Firefox windows has been closed, but downloader window is still opened. File is being downloaded with no issues. Firefox main windows is about to be opened again.
ff4-mod.png - New window is not responding, CPU usage has increased about 300%. It is not showed in the screenshot, but also downloader window has frozen.

New window finishes loading after 1 or 2 minute, and looks normal, but hangs again when user clicks something (trying to use the program).

Sorry for the bad english.
Hi, I finally decided to report this bug too. I met this issue with firefox 3.6, and now also with firefox 4 (updated today). Then I confirm it still exists on Firefox 4.

As previous post shows, I created an attachment showing the problem with the new firefox version.
(In reply to comment #6)
> Hi, I finally decided to report this bug too. I met this issue with firefox
> 3.6, and now also with firefox 4 (updated today). Then I confirm it still
> exists on Firefox 4.
> 
> As previous post shows, I created an attachment showing the problem with the
> new firefox version.

Me too have the same problem is that in FF 3.6 FF 4.
happens to me too, on FF4.
we know the current implementation of the download manager still uses synchronized processes, which is partially the problem here.  It scheduled for a rewrite however didn't quite make it for Fx4 although still being worked on.

I have noticed as well that its perceived as a hang or hung because depending on the the file type it can write to your temp cache folder before hitting the save button and it also runs an AV scan when its complete.  The images you save are redownloaded I believe and take longer then regular downloads.  These files might be in the image cache but I think are fetched again from the web.  

The other thing is, you can also turn off Real time scanning of Firefox downloads both with AV software and there is a pref in about:config to turn off scan after download.   

Thats about all I understand or can figure myself about this issue.
(In reply to comment #9)
> we know the current implementation of the download manager still uses
> synchronized processes, which is partially the problem here.  It scheduled
> for a rewrite however didn't quite make it for Fx4 although still being
> worked on.

Dale, is there a bug# where the work is occurring?
Severity: major → critical
Whiteboard: [closeme 2011-05-01]
(In reply to comment #10)
> (In reply to comment #9)
> > we know the current implementation of the download manager still uses
> > synchronized processes, which is partially the problem here.  It scheduled
> > for a rewrite however didn't quite make it for Fx4 although still being
> > worked on.
> 
> Dale, is there a bug# where the work is occurring?

DLM rewrite is bug 564934.
Depends on: DownloadsPanel
cant reproduce on Firefox 11, 12b4,13 and 14

for support please ask question in https://support.mozilla.org/questions/new
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → WORKSFORME
Whiteboard: [testday-20120413]
You need to log in before you can comment on or make changes to this bug.