Closed Bug 607293 Opened 11 years ago Closed 11 years ago

JM: Turn SETELEM into an IC

Categories

(Core :: JavaScript Engine, defect)

x86
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: dvander, Assigned: dvander)

References

Details

(Whiteboard: fixed-in-tracemonkey)

Attachments

(1 file, 1 obsolete file)

Like the GETELEM refactoring, this will split all of the excess fast-paths into ICs (there appears to be only one), and introduce a new IC type. It should be simpler though, since for this one we don't care about string keys yet.
Attached patch patch (obsolete) — Splinter Review
Tests caught some bugs along the way - amusingly, even an ES5 compliance bug which Jeff tells me is known ([].hasOwnProperty apparently lies with indexed setters)

This is about a reproducible 1-2ms win on access-fannkuch. Register use is a little better and indexed property checking dropped a bunch of loads.
Attachment #486550 - Flags: review?(dmandelin)
Attached patch remove dead codeSplinter Review
Attachment #486550 - Attachment is obsolete: true
Attachment #486551 - Flags: review?(dmandelin)
Attachment #486550 - Flags: review?(dmandelin)
Attachment #486551 - Flags: review?(dmandelin) → review+
http://hg.mozilla.org/mozilla-central/rev/85ea6b284b30
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Depends on: 615440
You need to log in before you can comment on or make changes to this bug.