Closed Bug 607418 Opened 9 years ago Closed 9 years ago

Intermittent failure in dom/tests/mochitest/localstorage/test_localStorageOriginsSchemaDiffs.html | FAILURE: X remains 1 in the master, expected 1 got null

Categories

(Core :: DOM: Core & HTML, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla2.0b10
Tracking Status
blocking2.0 --- -

People

(Reporter: philor, Assigned: mayhemer)

References

Details

(Keywords: intermittent-failure, regression, Whiteboard: [fixed by bug 624047] )

Attachments

(3 files, 2 obsolete files)

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1288117534.1288119906.6454.gz
Rev3 MacOSX Leopard 10.5.8 mozilla-central debug test mochitests-3/5 on 2010/10/26 11:25:34
s: talos-r3-leopard-035

6357 INFO TEST-PASS | /tests/dom/tests/mochitest/localstorage/test_localStorageOriginsSchemaDiffs.html | X is 1 in the master, expected 1 got 1
6358 INFO TEST-PASS | /tests/dom/tests/mochitest/localstorage/test_localStorageOriginsSchemaDiffs.html | X not set in the slave, expected null got null
6359 INFO TEST-PASS | /tests/dom/tests/mochitest/localstorage/test_localStorageOriginsSchemaDiffs.html | X set to 2 in the slave, expected 2 got 2
6360 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/localstorage/test_localStorageOriginsSchemaDiffs.html | FAILURE: X remains 1 in the master, expected 1 got null
This test has been untouched for over a year and a half, so this intermittent-failure looks like a real bug triggered by a recent code change.

Pushlog for the six days before this bug was reported:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b69aa5ff29d3&tochange=00c23130c7d1

That range includes two local-storage changes from Honza, but one of those two (Bug 527667) was backed out (and later relanded, but not until after this orange started happening).

So that leads me to suspect the other one -- Bug 536544 -- as the only likely cause here.  Tentatively marking as regression from that bug.
Blocks: 536544
Keywords: regression
-> me
Assignee: nobody → honzab.moz
Status: NEW → ASSIGNED
I added these check to mainly see if call to length attribute will reload the values.  length does recache the items in mItems hash table from the database.  I want to know if X disappeared from the db or just from mItems.
Attachment #493688 - Flags: review?(jst)
Attachment #493688 - Flags: review?(jst) → review+
Attachment #493688 - Flags: approval2.0+
Attachment #493688 - Attachment is obsolete: true
Attachment #494449 - Flags: review?(jst)
Attachment #494449 - Flags: approval2.0?
Attachment #494449 - Flags: review?(jst)
Attachment #494449 - Flags: review+
Attachment #494449 - Flags: approval2.0?
Attachment #494449 - Flags: approval2.0+
The test update was backed out because it triggered a JS_Assert.  I filed Bug 616217 for that.
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1291442939.1291443448.18676.gz
OS X 10.5 comm-central-trunk debug test mochitests-3/5 on 2010/12/03 22:08:59
As the previous version, but also doesn't forget to remove the observers.
Attachment #494449 - Attachment is obsolete: true
Comment on attachment 495519 [details] [diff] [review]
test update to have more logging 3 [Check in comment 40]

http://hg.mozilla.org/mozilla-central/rev/2b44a6a3bfd8
Attachment #495519 - Attachment description: test update to have more logging 3 → test update to have more logging 3 [Check in comment 40]
So, this is seen in the log:
Observed: domstorage-flush-timer
FAILURE: X remains 1 in the master, expected 1 got null
FAILURE: X remains 1 in the master, expected 1 got null
FAILURE: One item in the master, expected 1 got 0
FAILURE: X remains 1 in the master, expected 1 got null
FAILURE: One item in the master, expected 1 got 0
FAILURE: X remains 1 in the master, expected 1 got null

It proves that the flush is implemented wrong.  Also it proves that content of the physical database is wrong, not just mItems cache of the storage object.

I'll go after that now.
blocking2.0: --- → ?
Looks like the observer is still not properly removed.  This should help fix it.
Attachment #496978 - Flags: review?(jst)
Attachment #496978 - Flags: review?(jst) → review+
Attachment #496978 - Flags: approval2.0-
Not blocking on this, but I'll gladly approve additional test patches etc if they're needed.
blocking2.0: ? → -
Comment on attachment 496978 [details] [diff] [review]
test update to remove the observer properly [Check in comment 45]

http://hg.mozilla.org/mozilla-central/rev/baee733bafd8
Attachment #496978 - Attachment description: test update to remove the observer properly → test update to remove the observer properly [Check in comment 45]
This is just backout of two patches.  Self-reviewed patch.
Attachment #503019 - Flags: review+
Attachment #503019 - Flags: approval2.0?
Potential fix has been landed on mozilla-central:
http://hg.mozilla.org/mozilla-central/rev/0d08db0bf676
Attachment #503019 - Flags: approval2.0? → approval2.0+
Comment on attachment 503019 [details] [diff] [review]
revert all test debugging changes [Check in comment 57]

http://hg.mozilla.org/mozilla-central/rev/f6f30dac68f7
Attachment #503019 - Attachment description: revert all test debugging changes → revert all test debugging changes [Check in comment 57]
No reports for almost a month.  Bug 624047 fixed this.
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 624047
Flags: in-testsuite-
Resolution: DUPLICATE → FIXED
Whiteboard: [orange] → [fixed by bug 624047] [orange]
Target Milestone: --- → mozilla2.0b10
Flags: wanted-fennec1.0?
Flags: in-testsuite-
Flags: in-testsuite+
Flags: in-litmus?
Whiteboard: [fixed by bug 624047] [orange] → [fixed by bug 624047]
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.