Mozilla does not cache javascript and css files

VERIFIED DUPLICATE of bug 29370

Status

()

Core
Networking: Cache
P3
normal
VERIFIED DUPLICATE of bug 29370
18 years ago
18 years ago

People

(Reporter: Mirek Hankus, Assigned: neeti)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; m18) Gecko/20001119
BuildID:    2000111920

Bad:
   Mozilla does not cache *.js and *.css files. They are listed in about:cache,
but when you check logs of the server you are connecting you see something like
this:

212.244.251.34 - - [20/Nov/2000:14:49:50 +0100] "GET /arch.php HTTP/1.0" 200 9998
212.244.251.34 - - [20/Nov/2000:14:49:50 +0100] "GET /sheet.css HTTP/1.0" 200 1882
212.244.251.34 - - [20/Nov/2000:14:49:50 +0100] "GET /swap.js HTTP/1.0" 200 1006
212.244.251.34 - - [20/Nov/2000:14:49:51 +0100] "GET /publ.php HTTP/1.0" 200 16606
212.244.251.34 - - [20/Nov/2000:14:49:51 +0100] "GET /sheet.css HTTP/1.0" 200 1882
212.244.251.34 - - [20/Nov/2000:14:49:51 +0100] "GET /swap.js HTTP/1.0" 200 1006
212.244.251.34 - - [20/Nov/2000:14:49:52 +0100] "GET /arch.php HTTP/1.0" 200 9998
212.244.251.34 - - [20/Nov/2000:14:49:52 +0100] "GET /sheet.css HTTP/1.0" 200 1882
212.244.251.34 - - [20/Nov/2000:14:49:52 +0100] "GET /swap.js HTTP/1.0" 200 1006
212.244.251.34 - - [20/Nov/2000:14:49:53 +0100] "GET /publ.php HTTP/1.0" 200 16606
212.244.251.34 - - [20/Nov/2000:14:49:53 +0100] "GET /sheet.css HTTP/1.0" 200 1882
212.244.251.34 - - [20/Nov/2000:14:49:53 +0100] "GET /swap.js HTTP/1.0" 200 1006
212.244.251.34 - - [20/Nov/2000:14:49:54 +0100] "GET /arch.php HTTP/1.0" 200 9998
212.244.251.34 - - [20/Nov/2000:14:49:54 +0100] "GET /sheet.css HTTP/1.0" 200 1882
212.244.251.34 - - [20/Nov/2000:14:49:54 +0100] "GET /swap.js HTTP/1.0" 200 1006

In this exapmple i was switching between two pages.

GOOD:
  Mozilla should behave like Netscape 4.x. When i connect with Netscape in logs
there is only

212.244.251.34 - - [20/Nov/2000:14:50:22 +0100] "GET /arch.php HTTP/1.0" 200 9998
212.244.251.34 - - [20/Nov/2000:14:50:23 +0100] "GET /publ.php HTTP/1.0" 200 16606
212.244.251.34 - - [20/Nov/2000:14:50:24 +0100] "GET /arch.php HTTP/1.0" 200 9998
212.244.251.34 - - [20/Nov/2000:14:50:25 +0100] "GET /publ.php HTTP/1.0" 200 16606

All the images are cached ok (as you can see).


Reproducible: Always
Steps to Reproduce:
Open a page with Javascript and Styles located in different files. They will no
be cached.

Comment 1

18 years ago
THis is a dupe...
Summary: Mozilla does not cache jacascript and css files → Mozilla does not cache javascript and css files

Comment 2

18 years ago
Found it! :-) Sorry for the SPAM. :-(

This is a dupe of bug 29370 (Memory Cache doesn't work for CSS and JS files).



*** This bug has been marked as a duplicate of 29370 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 3

18 years ago
vrfy dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.