Elements with preformatted whitespace should treat newline characters as UBA paragraph breaks

RESOLVED DUPLICATE of bug 263359

Status

()

RESOLVED DUPLICATE of bug 263359
8 years ago
8 years ago

People

(Reporter: Ehsan, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
In elements where line breaks are not collapsed, e.g. <textarea> and elements
with white-space:pre|pre-line|pre-wrap, line breaks should constitute UBA
paragraph breaks.

When a line break introduces a UBA paragraph break, the base direction of the
new UBA paragraph will be determined by the computed direction of the nearest
ancestor element whose bidi properties require its contents to be in a separate
UBA paragraph (or sequence of paragraphs), e.g. a block element or an element
directionally isolated by the ubi attribute (which is being proposed in a
separate bug). Furthermore, for every element on the path in between that
results in the creation of an embedding or override level, e.g. a <bdo> element
or any element with a dir attribute or a value other than "normal" for the
unicode-bidi CSS property, the correspondeng embedding or override level is
re-introduced at the start of the new UBA paragraph (to be closed at the end of
the element or the UBA paragraph, whichever comes first).

For more information, see:
 * <http://www.w3.org/International/docs/html-bidi-requirements/#newline-as-separator>
 * <http://www.w3.org/Bugs/Public/show_bug.cgi?id=10812>
(Reporter)

Updated

8 years ago
Duplicate of this bug: 607640
Blocks: 613154
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 263359
You need to log in before you can comment on or make changes to this bug.