[JAEGER] Multiple cases failed in MONOIC only build.

RESOLVED FIXED

Status

()

Core
JavaScript Engine
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: Leon Sha, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 486275 [details] [diff] [review]
patch

Configuration:
--enable-debug --disable-optimize --disable-polyic

Failed cases:
jit-test/tests/basic/bug509639.js
jit-test/tests/basic/bug510642.js
jit-test/tests/basic/bug510655.js
......


These cases al have the same error message:
Assertion failure: ((size_t)atom & 0x7) == 0, at ../jsatom.h:79
(Reporter)

Updated

7 years ago
Attachment #486275 - Attachment is patch: true
Attachment #486275 - Attachment mime type: application/octet-stream → text/plain
Attachment #486275 - Flags: review?(dvander)
Comment on attachment 486275 [details] [diff] [review]
patch

dupe of bug 607203 ;)
Attachment #486275 - Flags: review?(dvander) → review+
(Reporter)

Comment 2

7 years ago
Thanks a lot.
I pushed this change and will close bug 607203.
http://hg.mozilla.org/tracemonkey/rev/1c573c884629
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Reporter)

Updated

7 years ago
Duplicate of this bug: 607203

Updated

7 years ago
Duplicate of this bug: 608997
You need to log in before you can comment on or make changes to this bug.