Last Comment Bug 607593 - WebGL crash [@mozilla::gl::GLContext::fFramebufferRenderbuffer]
: WebGL crash [@mozilla::gl::GLContext::fFramebufferRenderbuffer]
Status: RESOLVED FIXED
: crash, testcase
Product: Core
Classification: Components
Component: Canvas: WebGL (show other bugs)
: Trunk
: x86 Windows 7
: -- critical (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
: Benoit Jacob [:bjacob] (mostly away)
:
Mentors:
Depends on:
Blocks: 658170
  Show dependency treegraph
 
Reported: 2010-10-27 04:31 PDT by Christoph Diehl [:posidron]
Modified: 2012-01-20 11:26 PST (History)
3 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
unaffected
unaffected


Attachments
testcase (2.59 KB, application/zip)
2010-10-27 04:31 PDT, Christoph Diehl [:posidron]
no flags Details
callstack (1.18 KB, text/plain)
2010-10-27 04:32 PDT, Christoph Diehl [:posidron]
no flags Details

Description Christoph Diehl [:posidron] 2010-10-27 04:31:59 PDT
Created attachment 486323 [details]
testcase

Tested inside VMWare Fusion.

VMware SVGA 3D (Microsoft Corporation - WDDM)
Driver version: 7.14.1.42
Comment 1 Christoph Diehl [:posidron] 2010-10-27 04:32:27 PDT
Created attachment 486324 [details]
callstack
Comment 2 Benoit Jacob [:bjacob] (mostly away) 2010-10-27 04:44:42 PDT
This callstack looks like a bug in VMWare's OpenGL implementation. It internally converts a number to a string and that crashes. We can't do anything about it.

Incidentally, our framebufferRenderbuffer implementation is undergoing a rewrite, but that won't make a difference because we can't avoid calling glFramebufferRenderbuffer.
Comment 3 Benoit Jacob [:bjacob] (mostly away) 2010-10-27 04:47:23 PDT
Ah, it is still possible that we are bitten by GL asynchronousness making the stack trace irrelevant. If you want to rule that possibility out, grab a debug build of firefox and run with

   MOZ_GL_DEBUG=1 firefox

i.e. define the MOZ_GL_DEBUG environment variable to anything.
Comment 4 Benoit Jacob [:bjacob] (mostly away) 2012-01-20 11:26:55 PST
This is fixed since we started blacklisting other vendors than AMD/NVIDIA/Intel (so, all virtualization thingy^Wenvironments)

Note You need to log in before you can comment on or make changes to this bug.