Add-on bar appears on restart

RESOLVED DUPLICATE of bug 627484

Status

()

RESOLVED DUPLICATE of bug 627484
8 years ago
8 years ago

People

(Reporter: dibarnu, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101026 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101026 Firefox/4.0b8pre

The Add-on Bar reappears on launching Minefield even when it has been disabled via context menu previously.

Reproducible: Always

Steps to Reproduce:
1. Click an area near the top of the window to bring up the context menu for tool/menu bars (this is now exceedingly difficult, but keep clicking, you'll find an area that works)
2. Uncheck Add-on Bar
3. Quit Minefield
4. Restart Minefield
Actual Results:  
Add-on Bar is back from the dead like a Phoenix rising from the ashes.

Expected Results:  
Add-on Bar dead as a Dodo.

Hyperbole about the UI changes pushing me ever closer to IE 9 saved for people who care -- since Mozilla likes copying poorly thought out...oh, wait, Hyperbole ensued.
Same thing happening to me for the last several releases and up to/including the 11/02 nightly.

Comment 2

8 years ago
I can confirm, with the latest Firefox nightly (4.0~b8~hg20101108r57116+nobinonly-0ubuntu1~umd1~maverick) on Linux.
Right-click on the add-on bar to hide it... It will always re-appear in every window when starting Firefox.
Well, even when you just open a new window, that window will have the add-on bar, even if it has been hidden from every window.
If you have Firebug installed, you're hitting http://code.google.com/p/fbug/issues/detail?id=3556.
Reporter, anyone, can you reproduce this without Firebug installed?

Comment 5

8 years ago
(In reply to comment #4)
I can confirm this bug only happens when Firebug is enabled.
Duplicate of this bug: 611258
(In reply to comment #4)
> Reporter, anyone, can you reproduce this without Firebug installed?

I'm using Firebug as well, and Jeff (comment #3) is right.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
OS: Windows 7 → All
Resolution: --- → DUPLICATE
Version: unspecified → Trunk
Duplicate of bug: 627484
You need to log in before you can comment on or make changes to this bug.