Open Bug 607622 Opened 11 years ago Updated 9 months ago

The XML files generated by clicking the XML button at then end of buglists do not include attachment data

Categories

(Bugzilla :: Bug Import/Export & Moving, enhancement)

3.4.6
enhancement
Not set
normal

Tracking

()

People

(Reporter: fida.aljounaidi, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.9) Gecko/20100401 Ubuntu/9.10 (karmic) Firefox/3.5.9
Build Identifier: 3.4.6

Hi

I have a problem running importxml.pl on a 600 xml exported bugs.

The importxml.pl run successfully but the attached files were deleted.
So, i can see the attached filename but with the mention that this
file is deleted. To export the bugs list, i use the bugzilla
webinterface by selecting the xml button and registering the xml file
directly from the web browser (firefox 3.5.9).

When i use the bug moving option of bugzilla, so moving bug from the
web interface, i don't notice this problem. i can't continue doing
that because, the moving is interrupted when there is a big amount of
data.

Do you have any idea about that?



Thanks a lot 

Reproducible: Always

Steps to Reproduce:
1.search for a list of bug
2.Select XML and register the new XML imported list of bugs
3. From the destination server size execute the command 
perl -T importxml.pl -v -v File.xml
Actual Results:  
All bugs are imported but all the attached file were deleted. 
From the show_bug.cgi page i can see the name of the attached files but with the mention of (deleted). 
the column 'thedata' from the table 'attach_data' is empty. 

Expected Results:  
Successfull import with all the attached files
Looks like your problem is similar to bug 524926. Make sure your XML file contains the content of the attachments.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 524926
No 
It's not the same. Because i made the correction described on the bug 524926. The importxml ended successfully, but only the attached files name were transferred. 
Also, as i said, the moving bugs worked when i did it from the web interface of bugzilla. all the attached files were transfered with the correct data. 
I can't move all the bugs from the webinterface because it uses the mail server and moving a big amount of data with mail pipe crashes the server.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(In reply to comment #2)
> Also, as i said, the moving bugs worked when i did it from the web interface of
> bugzilla. all the attached files were transfered with the correct data. 

You mean when editing a single bug at once, right?


> I can't move all the bugs from the webinterface because it uses the mail server
> and moving a big amount of data with mail pipe crashes the server.

OK, now I see what you mean. This behavior is intentional, see the 2nd patch of bug 302669. We explicitly skip attachment data when clicking the XML button at the bottom of buglists, to avoid making the generated XML file too big.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: x86 → All
Summary: Attached files deleted after xml import → The XML files generated by clicking the XML button at then end of buglists do not include attachment data
Version: unspecified → 3.4.6
And to make things clear: the problem is not when *importing* bugs into the target Bugzilla, but when *exporting* bugs from the source Bugzilla by clicking the XML button.
Greg, is it intentional that you provided no way at all to include attachment data when clicking the XML button at the end of buglists? I just read the log of the channel again, on September 1st, 2005, and you said:

(18:55:46) <ghendricks> What we have added on our installation is a button at the bottom of buglist similar to Long Format which will give me all the listed bugs in xml
(18:57:17) <ghendricks> I am thinking of adding this to the patch for this bug and including a checkbox option to allow people to include the attachment data
(18:57:35) <ghendricks> Thoughts?
(18:57:47) <LpSolit> ghendricks: you should first ask myk about the UI
(18:58:51) <ghendricks> myk: ping?
(23:21:56) <ghendricks> what about the UI changes?
(23:23:12) <myk> ghendricks: haven't looked at those yet, sorry
(23:25:29) <myk> ghendricks: at first glance, they look fine

So you suggested to add a checkbox to include attachment data, but it never appeared in your patches.

Fida, in the meanwhile, all you have to do is to remove the excludefield parameter from the URL (it's a POST URL, so you need e.g the Urlparams Firefox extension to remove it). But be aware that you can end with a several tens of MB file!
You need to log in before you can comment on or make changes to this bug.