Bookmark opened by clicking the scroll wheel via a bookmark folder may temporarily freeze the navigation bar

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: Jean-Philippe HALIMI, Unassigned)

Tracking

4.0 Branch
All
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:2.0b8pre) Gecko/20101026 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:2.0b8pre) Gecko/20101026 Firefox/4.0b8pre

If you insert a subfolder into a bookmark folder, and then you insert a bookmark inside this subfolder, when you click it with your scroll wheel, it freezes the navigation bar fields, instead of opening it in a new tab ; then, you can't write anything into the address bar or into the search field for a certain time. As far as I can remember it's an old bug that is really annoying. After this little time, you're able to write into these fields again. This bug occurs about 50% of the time.

Reproducible: Sometimes

Steps to Reproduce:
1. Create a new bookmark folder into your bookmark toolbar
2. Create a subfolder into this bookmark folder
3. Insert any site into this subfolder
4. Try open it in a new tab clicking it with the scroll wheel

5. If the bug occurs, anything happens
6. Try open a new tab, and see you cannot click the address bar and the search field

7. If the bug does not occur, I don't know how to make it happen. Maybe try another website...
Actual Results:  
- The new tab is not opened.
- You cannot write anything inside the address bar and the search field

Expected Results:  
- The bookmark should be opened in a new tab
- The address bar and the search field should always be accessible
is the browser like "not responding" or it just does not take focus?
have you tried safe mode to remove add-ons from possible culprits list? http://support.mozilla.com/kb/Safe+Mode
(Reporter)

Comment 2

8 years ago
@Marco Bonardo: The problem is this issue does not occur every single time I try to open a sub-folder bookmark. But the problem still exists, even with Firefox 4b7. The browser does not freeze, the bug only appears in the address bar and in the search field, which is very annoying while surfing.

When you try to write something onto the address bar, the default text "Go to a website" does not dissapear. You can't write anything on it.

On the search field, the search engine's name in italic (for instance, Google) does not dissapear either, though you can write text on it. In this case, your search is written above the text in italic. Weird... I will try to make a video next time to show how it occurs.

Comment 3

7 years ago
Build identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b10pre) Gecko/20110118 Firefox/4.0b10pre

I can't reproduce this. Clicking the bookmark with the scroll wheel works as expected.
Still reproduceable in final version?
(Reporter)

Comment 5

7 years ago
Actually I don't use the bookmarks bar anymore since there is a shortcut. I think you should close this one, if I see it again, I will make another report.

Comment 6

7 years ago
Closing bug as WFM based on comment 5 - if you are still experiencing this issue or have more information to provide feel free to post back here and we can re-open the bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
Version: unspecified → 4.0 Branch
You need to log in before you can comment on or make changes to this bug.