An idea to make selecting search plugins easier

RESOLVED DUPLICATE of bug 1088660

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 1088660
8 years ago
3 years ago

People

(Reporter: yaoziyuan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.10) Gecko/20100920 Fedora/3.6.10-1.fc13 Firefox/3.6.10
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.10) Gecko/20100920 Fedora/3.6.10-1.fc13 Firefox/3.6.10

When the user has to frequently search with various search plugins, switching search plugins can be made easier:

As the user starts typing/pasting a query in Firefox's search box, a dynamic list can automatically show up beneath the search box, showing relevant historical queries and available search buttons (each button represents a search plugin). This way, the user doesn't have to manually open up the search plugins dropdown list as usual, saving himself a point-and-click. What he now has to do is just to type/paste his query and press Enter to go with the default search plugin, or click a search button in the automatically opened dropdown list.

Reproducible: Always

Steps to Reproduce:
It's a feature request. See above.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1088660
You need to log in before you can comment on or make changes to this bug.