The default bug view has changed. See this FAQ.

<video> element seek is inaccurate

VERIFIED DUPLICATE of bug 626273

Status

()

Core
Audio/Video
VERIFIED DUPLICATE of bug 626273
7 years ago
6 years ago

People

(Reporter: Silvia Pfeiffer, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6

When I seek to a time, e.g. video.currentTime = 20, I never end up at that exact time, but rather a little earlier, e.g. video.currentTime = 19.999000549316406. This is visually perceivable by the user through an irritating display of "19" in the user interface rather than the expected "20".

Opera and Google Chrome report the currentTime accurately and their controls display agrees with that.

(previously reported as a comment on bug 587465)

Reproducible: Always

Steps to Reproduce:
1. use a <video> element
2. do a seek in JS: video.currentTime=20;
3. check video.currentTime and the user interface
Actual Results:  
currentTime is smaller than 20

Expected Results:  
currentTime is exactly 20
Component: General → Video/Audio
Product: Firefox → Core
QA Contact: general → video.audio
This is mostly fixed by bug 626273, I think.
Depends on: 626273
WFM. :)

Silvia: would you be able to test if this is fixed in a current nightly and let is know please? Thanks!
(Reporter)

Comment 3

6 years ago
Yup, I can confirm it works. Thanks for the awesome effort - getting this stuff right is not trivial.
Great, thanks Silvia.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 626273
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.