[SeaMonkey 2.0, Windows] Packaged tests are not run anymore

RESOLVED FIXED

Status

--
major
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: sgautherie, Assigned: kairo)

Tracking

(Blocks: 1 bug, {regression})

SeaMonkey 2.0 Branch
x86
Windows Server 2003
regression
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Since at least 2010/09/17 :-(
Flags: in-testsuite-
(Reporter)

Comment 1

8 years ago
I checked config.py but didn't notice anything unexpected there.
I have no clue.
(Assignee)

Comment 2

8 years ago
The columns are there on the buildbot waterfall, I guess they are not triggered any more though.
(Assignee)

Comment 3

8 years ago
WINNT 5.2 comm-1.9.1 unit test: steps/sendchange/logs/stdio has

python /e/builds/slave/comm-1.9.1-win32-unittest/tools/buildfarm/utils/retry.py -s 5 -t 1800 -r 5 --stdout-regexp change sent successfully buildbot sendchange --master cb-seamonkey-linuxmaster-01.mozilla.org:9010 --username sendchange-unittest --branch comm-1.9.1-win32-unittest --revision None http://stage.mozilla.org/pub/mozilla.org/seamonkey/tinderbox-builds/comm-1.9.1-win32-unittest/1288252726/seamonkey-2.0.10pre.en-US.win32.zip
 in dir e:\builds\slave\comm-1.9.1-win32-unittest\build (timeout 1200 secs)
 [...]python: can't open file '/e/builds/slave/comm-1.9.1-win32-unittest/tools/buildfarm/utils/retry.py': [Errno 2] No such file or directory
program finished with exit code 2
(Assignee)

Comment 4

8 years ago
I tried to solve this with http://hg.mozilla.org/build/buildbotcustom/rev/559708821cb9
(Assignee)

Comment 5

8 years ago
Created attachment 488793 [details] [diff] [review]
move the toolsdir override

For correctness, seeking review for this patch. The reason it should help is because the path we call retry.py with only differs to the debug builds that invoke them on trunk by the working ones having a leading "e:" while the failing ones have a leading "/e/" in the path, so I guess we need the difference right in that sendchange call inside the upload diff (last thing to be invoked there) but we only rewrite it to be Windows-style right after this. The patch moves it to be before that, which actually matches what the original UnittestBuildFactory is doing.
Assignee: nobody → kairo
Status: NEW → ASSIGNED
Attachment #488793 - Flags: review?(gozer)
(Assignee)

Comment 6

8 years ago
(In reply to comment #4)
> I tried to solve this with
> http://hg.mozilla.org/build/buildbotcustom/rev/559708821cb9

This on the buildbot-0.7 branch and applied to our master has solved the original bug, but I'll only mark this fixed once this has reviews and landed on the default branch.
(Reporter)

Updated

8 years ago
Blocks: 550963
(Reporter)

Updated

8 years ago
Blocks: 610565
Attachment #488793 - Flags: review?(gozer) → review+
(Assignee)

Comment 7

8 years ago
Thanks, checked in on default branch as http://hg.mozilla.org/build/buildbotcustom/rev/9e536c53028b
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Updated

8 years ago
Blocks: 622255
No longer blocks: 550963
You need to log in before you can comment on or make changes to this bug.