Closed Bug 607972 Opened 12 years ago Closed 12 years ago

Async plugins: reftest failure with opaque plugin with 50% opacity

Categories

(Core Graveyard :: Plug-ins, defect)

x86
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 607958

People

(Reporter: benjamin, Unassigned)

References

Details

Async plugins on Windows has one reftest failure:

REFTEST TEST-START | file:///c:/talos-slave/maple_win7_test-reftest/build/reftest/tests/modules/plugin/test/reftest/plugin-alpha-opacity.html
REFTEST TEST-START | file:///c:/talos-slave/maple_win7_test-reftest/build/reftest/tests/modules/plugin/test/reftest/div-alpha-opacity.html
REFTEST TEST-UNEXPECTED-FAIL | file:///c:/talos-slave/maple_win7_test-reftest/build/reftest/tests/modules/plugin/test/reftest/plugin-alpha-opacity.html |

http://tinderbox.mozilla.org/showlog.cgi?log=Maple/1288273978.1288275223.21690.gz

The testcase involves an opaque testplugin which is then given 50% opacity using CSS:
http://mxr.mozilla.org/mozilla-central/source/modules/plugin/test/reftest/plugin-alpha-opacity.html?force=1

The color of the testplugin is off. Things that I'm pretty sure are *not* the cause:

* Plugin painting the right color: I've verified that the bitmap bits painted by the plugin are correctly 0xFFA0A0A0
* Premultiplied alpha issues: the plugin isn't painting alpha, so there are no premultiplication issues

I can verify that this same test passes when I disable IPC or disable async-layered-painting. Right now I want to blame the layer system for painting the wrong color. Bas/Jeff, can I get one of you guys to diagnose and fix this one? You can either use hourly builds from the maple project branch, or pull and build maple. This is not a beta7 blocker, but it's probably close to top priority after that.
Argh, session-restore made a duplicate?
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 607958
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.