Can't change email address in user profile

RESOLVED WONTFIX

Status

P2
normal
RESOLVED WONTFIX
8 years ago
5 years ago

People

(Reporter: jswisher, Unassigned)

Tracking

Details

(Whiteboard: u=contributor c=bug p=, URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b6) Gecko/20100101 Firefox/4.0b6
Build Identifier: 

Attempting to change email address in user profile fails with an error message about the password being incorrect, even though the password is correct.

Reproducible: Always

Steps to Reproduce:
1. Login to the MDN Forums.
2. Go to the "Edit account settings" page of the "User Control Panel".
3. Enter a new email address, and enter it again to confirm it.
4. Enter the current password.
5. Click Submit.
Actual Results:  
Message: The current password you entered is incorrect.

The "new" email address appears in the "E-mail address" field. However, if you leave the page and return, the old one is still there.

Expected Results:  
No error message, because the password is correct (was just used for logging in).

The "new" email address should appear in the "E-mail address" field, and remain there across page accesses.

Comment 1

8 years ago
I couldn't find this place from within MDC, which isn't a good sign either. Thanks for the relocate.

Comment 2

8 years ago
assigning to oremj to take a look at the phpbb config.  it'll be great to have this fixed for 0.9.2
Assignee: nobody → jeremy.orem+bugs
Target Milestone: --- → 0.9.2
Austin, can you take a look at the admin settings or give me the admin password. Is there anything in the custom auth plugin that would prevent people from changing their password?
Assignee: jeremy.orem+bugs → ozten.bugs
(In reply to comment #3)
> can you take a look at the admin settings or give me the admin
password

I don't have the production admin password.

> Is there anything in the custom auth plugin that would prevent people
from changing their password?

I'm not familiar with this code yet, I can take a look.

Comment 5

8 years ago
i think janet has admin access to the prod phpbb.

janet:  can you look into the admin settings to see if we can fix this?  sounds like there is a setting we need to update.
Target Milestone: 0.9.2 → ---
(Reporter)

Comment 6

8 years ago
It looks like the relevant setting is "Can change e-mail address". It appears that this is set to "Yes" for all groups except "Guests", yet changing e-mail addresses is not working.
Whiteboard: 0.9.2.1
(In reply to comment #6)
After digging into our mods on top of phpbb...

Everytime you log into phpBB, we sync it up with your MDN account. If you're Deki username/email don't match the phpbb values, then it copies Deki values into phpbb.

Workaround: You can change your email address in Deki. I've just verified this works and after the next login, my forums email address was updated.
Possible solution:
We could *disable* Can change e-mail address, and add some copy around where the user would try to change their email address which points them to the deki screen.
Whiteboard: 0.9.2.1
(Reporter)

Comment 9

8 years ago
Similar error message for changing password:
http://mdn.uservoice.com/forums/51389-mdn-website-feedback-http-developer-mozilla-org/suggestions/1266295-try-to-set-a-new-password-in-the-user-control-pane

I haven't tried to reproduce this yet, but it's probably also due to the account syncing from Deki. If so, need to disable all account changes on the phpBB side, and direct users to the Deki side.

Comment 10

8 years ago
We decided today that it is best to just disable any editing of profile data in phpbb and encourage users edit their Deki profiles instead.

We may have to live with this until after the SSO and demo room work is done, but we should definitely shoot to disable and provide a message pointing to Deki profiles soon after that.
(Reporter)

Comment 11

8 years ago
Is there an ETA on disabling the editing of phpbb profile data? I heard from another understandably confused user today.
OS: Mac OS X → All
Priority: -- → P2
Hardware: x86 → All
Whiteboard: u=contributor c=profiles p=
taking away from poor ozten. ;)

this goes away when we disable phpbb altogether, right?
Assignee: ozten.bugs → nobody
Whiteboard: u=contributor c=profiles p= → u=contributor c=bug p=
(In reply to Luke Crouch [:groovecoder] from comment #13)
> taking away from poor ozten. ;)
> 
> this goes away when we disable phpbb altogether, right?

You bet!
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
Version: MDN → unspecified
Component: Forums → Other
You need to log in before you can comment on or make changes to this bug.