Closed Bug 608300 Opened 14 years ago Closed 14 years ago

Terminating hung Silverlight does not un-freeze the browser window

Categories

(Core Graveyard :: Plug-ins, defect)

x86
Windows 7
defect
Not set
major

Tracking

(blocking2.0 final+)

RESOLVED FIXED
Tracking Status
blocking2.0 --- final+

People

(Reporter: spammaaja, Assigned: jimm)

References

()

Details

(Keywords: hang)

User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b6) Gecko/20100101 Firefox/4.0b6
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101029 Firefox/4.0b8pre

Terminating hung Silverlight does not un-freeze the browser window. It seems to affect only the window with Silverlight - other windows are unaffected. It responds to keyboard, but not to mouse.

Reproducible: Always

Steps to Reproduce:
1. Go to the url
2. Click the fullscreen button -> browser freezes (bug 602502)
3. Terminate plugin-container.exe
4. Attempt to use mouse
5. Attempt to open links with keyboard (tab, enter)
Actual Results:  
The window stays frozen, and only responds to keyboard commands.

Expected Results:  
The window should unfreeze.
blocking2.0: --- → ?
See Also: → 602502
Version: unspecified → Trunk
Keywords: hang
Dupe, I think...
will likely be fixed by bug 570249 but unfortunately that can't land at the moment.
Blocking, but we'll hopefully just test/resolve this when bug 570249 lands.
Assignee: nobody → jmathies
blocking2.0: ? → final+
(In reply to comment #2)
> will likely be fixed by bug 570249 but unfortunately that can't land at the
> moment.

Confirmed fixed by the patch that just landed there. The core problem with the dialog is still tracked by bug 602502.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.