Closed Bug 608459 Opened 11 years ago Closed 7 years ago

basic authentication doesnt allow choice of username

Categories

(Toolkit :: Password Manager, defect)

defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 227632

People

(Reporter: mozilla, Unassigned)

Details

(Whiteboard: [SmBugEvent])

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.14) Gecko/20100930 SeaMonkey/2.0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.14) Gecko/20100930 SeaMonkey/2.0.9

When encountering a site requiring basic authentication seamonkey does not allow selection of the username desired.  So if one has multiple authentication usernames (and passwords) seamonkey only always uses the first one.  No choice is possible, but and additional username and password is correctly stored in password database.

Reproducible: Always

Steps to Reproduce:
1. connect to site requiring basic authentication
2. ensure have registered with multiple usernames (and password)
3.
Actual Results:  
no choice of usernames presented.

Expected Results:  
Should be possible to choice the username to use.


Older seamonkey (pre 2.0) used to work properly.
I see the same issue with Firefox Aurora 5.0a2, so moving to Toolkit.
Status: UNCONFIRMED → NEW
Component: General → Password Manager
Ever confirmed: true
OS: Windows XP → All
Product: SeaMonkey → Toolkit
QA Contact: general → password.manager
Hardware: x86 → All
Whiteboard: [SmBugEvent]
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 227632
You need to log in before you can comment on or make changes to this bug.