Embedded video elements (flash, silverlight) destroy Firefox GUI when scrolled out of scope

RESOLVED DUPLICATE of bug 590568

Status

()

--
major
RESOLVED DUPLICATE of bug 590568
8 years ago
8 years ago

People

(Reporter: alexander.zink, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101030 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101030 Firefox/4.0b8pre

The Firefox application framework GUI is destroyed when scrolling a page vertically (e.g. using the mouse scroll wheel), which carries an embedded Flash/Silverlight/... video element. As soon as the area of the video element reaches the top of the view port, it starts blanking Firefox's GUI elements (address bar, tab bar, even the Window title bar) in the area that would be covered by the video element outside the current viewport of the page.
Note that this blanked area is painted with white background (i.e. the actual video content is only shown within the viewport).

Reproducible: Always

Steps to Reproduce:
Load a page with an embedded Flash/Silverlight/... video element, and scroll down vertically until after the video element scrolls out of the view port.
Actual Results:  
Firefox's GUI elements are overwritten with white background in all places that would be covered by the video box if it were not clipped by the viewport.

The GUI elements can be restored (re-drawn) by hovering each blanked element with the mouse.

Expected Results:  
Parts of embedded video elements outside the window's viewport must not affect the application GUI in any way.

Comment 1

8 years ago
Yes I can confirm and reproduce this bug in my Firefox4b7

Comment 2

8 years ago
OK just had a quick play and this only happens when you have "Use hardware acceleration when available" checked. If you disable this option then objects scroll as expected.

Comment 3

8 years ago
I can confirm this too.

---
Sony VAIO VGN-AR41E
Windows 7
NVidia Geforce 8400M GT (Driver v167.60)
---

I will upload a screenshot of the issue. Note: the white artifact is cleaned up if you move your mouse cursor around the window a bit (triggering repaints, I assume).

The white area will go as far as the very top of the window (covering the orange Firefox button). If you enable the menu bar permanently, the orange button disappears and the white will no longer extend into the title bar - it still covers the menu and navigation bars though.

Comment 4

8 years ago
Created attachment 490398 [details]
Example of white artifact caused when flash object is scrolled out of the visible viewport of the window.

Comment 5

8 years ago
fixed for me with even d3d9 prefer true and the build 20101113

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 590568
You need to log in before you can comment on or make changes to this bug.