Closed Bug 608549 Opened 12 years ago Closed 12 years ago

"ABORT: Negative sample time for active animation"

Categories

(Core :: SVG, defect)

defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla2.0b8
Tracking Status
blocking2.0 --- final+

People

(Reporter: jruderman, Assigned: birtles)

References

Details

(Keywords: assertion, testcase)

Attachments

(2 files)

###!!! ABORT: Negative sample time for active animation: 'mSampleTime >= 0 || !mIsActive', file content/smil/nsSMILAnimationFunction.cpp, line 244
Assignee: nobody → birtles
Status: NEW → ASSIGNED
blocking2.0: --- → ?
Attached patch Patch v1aSplinter Review
Proposed fix. Adds range checks for calls to begin/endElement.
Attachment #488408 - Flags: review?(dholbert)
Duplicate of this bug: 606632
Comment on attachment 488408 [details] [diff] [review]
Patch v1a

Nit: Could you tweak the test so it checks both beginElementAt and endElementAt?

Perhaps like this:

  try {
    set.beginElementAt(NaN);
    return;
  } catch (e) {}
  try {
    set.endElementAt(NaN);
    return;
  } catch (e) {}

  // if we got here, we threw exceptions and skipped both early-returns,
  // as expected.
  document.documentElement.removeAttribute("class");

r=dholbert with that change.
Attachment #488408 - Flags: review?(dholbert) → review+
OS: Mac OS X → All
Hardware: x86 → All
Pushed: http://hg.mozilla.org/mozilla-central/rev/a0976b5560af
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b8
You need to log in before you can comment on or make changes to this bug.