commonDialog icon and text are misaligned

RESOLVED FIXED in mozilla2.0b10

Status

()

Toolkit
General
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: mcdavis941 (sporadically reading bugmail), Assigned: Dolske)

Tracking

({regression})

Trunk
mozilla2.0b10
x86
Windows Vista
regression
Points:
---

Firefox Tracking Flags

(blocking2.0 -)

Details

Attachments

(2 attachments)

In common dialogs, the vertical alignment of the text relative to the icon (on Windows, I didn't look at Linux) has changed between Fx3.6 and the 2010-10-30 nightly.

Looking at several other popups from other apps and from Windows itself, it seems like the convention is to more-or-less align the top of the text with the top of the icon.  It was that way for Fx3.6, but it's lower now for Fx4.  Seems like a regression.

This looks like it has to do with hiding the title (Bug 563274, Bug 575485) on platforms other than Mac.  Maybe also hide the spacer whenever the title is hidden?

Screenshot coming.
Created attachment 487237 [details]
screenshot
Nominating for blocking, because I'm not sure how important a bug this is considered in UI-land...
blocking2.0: --- → ?
Keywords: regression
Just to amplify a little:

The dialogs at issue are the ones shown with window.alert(), window.prompt(), and window.confirm(), i.e., the ones represented by commonDialog.xul.

STR is just window.alert('your text here'), and compare the result on 3.6 vs. a trunk nightly.

The title mentioned above is <description id="info.title"> in commonDialog.xul, and the spacer is the element right after it.  The in-dialog title is there because on the Mac there's no title above the dialog (no windowframe, no titlebar), so it's shown inside the dialog itself -- but only on the Mac.  The spacer is there to separate the text of the in-dialog title (when that is shown) from the text that follows it.  When the in-dialog title is hidden, the spacer should be hidden too (I think), else you get the extra vertical space.

http://mxr.mozilla.org/mozilla-central/source/toolkit/components/prompts/content/commonDialog.xul#60

CCing Dolske because he worked on Bug 575485.

I don't know how much this matters either, but the icon does seem to stick out a little now.
(Assignee)

Comment 4

7 years ago
Not blocking, but a polish nit we should fix. Will pick this up, perhaps in the course of something else.
Assignee: nobody → dolske
blocking2.0: ? → -
Component: General → General
Product: Core → Toolkit
QA Contact: general → general
(Assignee)

Comment 5

7 years ago
Created attachment 503092 [details] [diff] [review]
Patch v.1

Trivial fix.
Attachment #503092 - Flags: review?(gavin.sharp)
Attachment #503092 - Flags: review?(gavin.sharp) → review+
Attachment #503092 - Flags: approval2.0+
(Assignee)

Updated

7 years ago
Summary: commonDialog icon-to-text alignment has changed between fx3.6 and fx4 → commonDialog icon and text are misaligned
(Assignee)

Comment 6

7 years ago
Pushed http://hg.mozilla.org/mozilla-central/rev/8b7333bb30b5
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b10
Depends on: 625814
You need to log in before you can comment on or make changes to this bug.