Closed Bug 608721 Opened 9 years ago Closed 9 years ago

Next character of U+3001 or U+3002 should break line even if it is "["

Categories

(Core :: Internationalization, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla2.0b9

People

(Reporter: m_kato, Assigned: masayuki)

References

Details

Attachments

(2 files)

Attached file test case
U+3001 (IDEOGRAPHIC COMMA) or U+3002 (IDEOGRAPHIC FULL STOP) has to break line even if next is "[".
Summary: U+3001 or U+3002 should break line even if next is "[" → Next character of U+3001 or U+3002 should break line even if it is "["
Attached patch Patch v1.0Splinter Review
The cause is a mistake of the definition table of where is breakable point between two classes. The CJK punctuations are defined as class-[a] (Punctuation that prohibits break before) and the open parentheses are defined as class-[c] (Open parentheses like Character (See bug 389056)) rather than class-0 (Open parenthesis).

Looks like I prevented the break in bug 389056 comment 14. But at bug 389056 comment 23, I addedn class-[d] (Close parenthese (or punctuations) like Character (See bug 389056)) which is separated from class-[a] for preventing the breaks between class-[a] and class-[c]. So, now, we can break between them.

Note that class-[a] is used for some Japanese characters, symbols and few characters of complex script (Thai and Lao). Looks like the Japanese characters don't have any problems with this change. Some symbols *might* have some troubles. But then, we should change their class to [d]. I'm not sure about the complex characters. However, they aren't used for most cases because they should be next to complex class. Then, the characters should be checked by native line breaker.
Assignee: m_kato → masayuki
Status: NEW → ASSIGNED
Attachment #497763 - Flags: review?(roc)
http://hg.mozilla.org/mozilla-central/rev/25fc0d97436f
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b9
You need to log in before you can comment on or make changes to this bug.