Last Comment Bug 608751 - zero-length line strokes are not visible even with round or square line caps
: zero-length line strokes are not visible even with round or square line caps
Status: RESOLVED DUPLICATE of bug 589648
:
Product: Core
Classification: Components
Component: SVG (show other bugs)
: unspecified
: x86 Linux
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-01 09:30 PDT by David A. Madore
Modified: 2010-11-01 10:07 PDT (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description David A. Madore 2010-11-01 09:30:30 PDT
The SVG specification states (<URL: http://www.w3.org/TR/SVG/implnote.html#PathElementImplementationNotes >):

> Do draw the linecap for zero-length path segments when
'stroke-linecap' is set to either round or square.  (This allows round
and square dots to be drawn on the canvas.)

This is not implemented by Firefox 3.5 or 3.6 (I believe Firefox 3.0 was correct, however, so it's a regression), at least under certain Linux versions (I suppose it is due to the implementation backend: tested under Debian 5.0.6 Lenny=testing, and Ubuntu 10.04 Lucid Lynx LTS).

Example problem: the page <URL: http://www.madore.org/~david/.tmp/higman-sims-17-0ls.svg > should render identically to <URL: http://www.madore.org/~david/.tmp/higman-sims-17.svg >, but is missing the thick red dots.

Bug #355842 was apparently similar, but closed a long time ago (another sign that this is probably a regression).

FWIW, Chrome apparently suffers from the same bug: <URL: http://code.google.com/p/chromium/issues/detail?id=21057 >.
Comment 1 Robert Longson 2010-11-01 10:07:28 PDT
Round works on trunk. Marking this a duplicate of the existing square bug.

*** This bug has been marked as a duplicate of bug 589648 ***

Note You need to log in before you can comment on or make changes to this bug.