Enabling methodjit in chrome regresses Ts and Tshutdown

RESOLVED INVALID

Status

()

defect
RESOLVED INVALID
9 years ago
8 years ago

People

(Reporter: mfinkle, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

Are there things we can do to reduce the effects of methodjit on startup and shutdown?
Regression Ts increase 3.53% on Nokia n900 mobile
----------------------------------------------------
    Previous: avg 6990.074 stddev 105.673 of 30 runs up to revision aa1334b58f2f
    New     : avg 7237.112 stddev 9.717 of 5 runs since revision e67c727487a8
    Change  : +247.038 (3.53% / z=2.338)
    Graph   : http://mzl.la/a4FO7D

Changeset range: http://hg.mozilla.org/mobile-browser/pushloghtml?fromchange=aa1334b58f2f&tochange=e67c727487a8


Regression Ts Shutdown increase 95.5% on Nokia n900 mobile
-------------------------------------------------------------
    Previous: avg 1474.241 stddev 40.252 of 30 runs up to revision aa1334b58f2f
    New     : avg 2882.334 stddev 87.119 of 5 runs since revision e67c727487a8
    Change  : +1408.093 (95.5% / z=34.982)
    Graph   : http://mzl.la/bxh004

Changeset range: http://hg.mozilla.org/mobile-browser/pushloghtml?fromchange=aa1334b58f2f&tochange=e67c727487a8
Where is the time being spent?  Doubling the shutdown time should show up like a supernova on a profile of it.
I had some oprofile logs from startup. Will attach
Do you have callgraph without mjit enabled? just to compare it correctly... or how did you get this profile?
(In reply to comment #8)
> Do you have callgraph without mjit enabled?

Not at the moment. I could probably make some

> just to compare it correctly... or
> how did you get this profile?

These profiles are with methodjit enabled
Blocks: 622536
Can we make some build request and measure Ts with mjit enabled/disabled again?
chrome mjit did not regress startup the next time we enabled it, but we disabled it again for memory reasons.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.