Closed Bug 609207 Opened 11 years ago Closed 11 years ago

wyciwyg moved to necko_wyciwyg.xpt, but Firefox isn't shipping it

Categories

(Firefox Build System :: General, defect)

defect
Not set
normal

Tracking

(blocking2.0 betaN+)

RESOLVED FIXED
mozilla4.0b8
Tracking Status
blocking2.0 --- betaN+

People

(Reporter: philor, Assigned: philor)

References

Details

Attachments

(1 file)

Attached patch FixSplinter Review
Since it's such a hidden mystery, I don't really have any feeling for how likely it is that some complicated addon doing weird things with wyciwyg:// will be broken by this, but, bug 561085 moved nsIWyciwygChannel.idl out of content_htmldoc.xpt, where it was getting shipped, and into necko_wyciwyg.xpt, where it is not getting shipped since that's not listed in the package-manifest.

I've always been a pretty crappy driver, but I think if I was driving, I'd call it a b7 blocker if I was a day away from freezing. Not sure what I'd say if I was looking at having to have a build 2 for it.
Attachment #487832 - Flags: review?(ted.mielczarek)
blocking2.0: --- → ?
Comment on attachment 487832 [details] [diff] [review]
Fix

I guess we don't actually use this in a scriptable manner anywhere that would have failed without this being shipped. I would be surprised to find that this broke any addons either, but addons do always find new and exciting ways to break things.
Attachment #487832 - Flags: review?(ted.mielczarek) → review+
Attachment #487832 - Flags: approval2.0?
Attachment #487832 - Flags: approval2.0? → approval2.0+
blocking2.0: ? → betaN+
http://hg.mozilla.org/mozilla-central/rev/8a5b02198b90
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b8
Component: Build Config → General
Product: Firefox → Firefox Build System
Keywords: regression
Target Milestone: Firefox 4.0b8 → mozilla4.0b8
You need to log in before you can comment on or make changes to this bug.