Event acceptance may be sent from wrong account

RESOLVED DUPLICATE of bug 475886

Status

RESOLVED DUPLICATE of bug 475886
8 years ago
2 years ago

People

(Reporter: alaric, Unassigned)

Tracking

Lightning 1.0b4
x86
Linux

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.12) Gecko/20101029 Gentoo Firefox/3.6.12
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.12) Gecko/20101101 Lightning/1.0b3pre Thunderbird/3.1.6

I have five email accounts configured in Thunderbird.  The first three are personal accounts on my ISP's mail server, the fourth is a personal account on my local mail server, and the fifth is a company email account on my employer's Exchange mail system.  If I receive mail from the company account containing an event notification, 

Reproducible: Always

Steps to Reproduce:
1. Set up multiple accounts in Thunderbird.
2. Send an Outlook event notification to an account other than the first.
3. Accept the event.  Check "Support Outlook..." for the reply.  (I don't know whether this step is necessary, but it's what I'm doing.)
4. Check the Sent folders to see which account the reply was sent from.
Actual Results:  
The reply is always sent from the first account, regardless of which account received the event notification.

Expected Results:  
The reply should always be sent from the account that received the event notice.
(Reporter)

Comment 1

8 years ago
er ...  "If I receive mail from the company account containing an event notification, and I accept the event, the reply is sent from the wrong account."
Component: General → Lightning Only
Product: Thunderbird → Calendar
QA Contact: general → lightning
Lightning uses the email account that is configured for the corresponding calendar. Did you select the correct email account in the calendars properties dialog?
(Reporter)

Comment 3

8 years ago
(In reply to comment #2)
> Lightning uses the email account that is configured for the corresponding
> calendar. Did you select the correct email account in the calendars properties
> dialog?

Ummm...   Until you asked that, honestly, I neither knew that I could or needed to.  I just went and figured out by experimentation how to get to the calendar properties, and it turns out that when Thunderbird created the calendar, it did so using the first account it found; then when event notifications were sent to me, it went ahead and silently used the same calendar even though the email address didn't match.

I've now changed the properties on that calendar and set it to use the correct account, but it seems to me this behavior could do with improvement.  It booby-trapped me quite effectively.
Component: Lightning Only → E-mail based Scheduling (iTIP/iMIP)
QA Contact: lightning → email-scheduling
Version: unspecified → Lightning 1.0b4

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 475886
You need to log in before you can comment on or make changes to this bug.