Closed Bug 609405 Opened 10 years ago Closed 9 years ago

Can't make new window when active window is on secondary monitor after switching monitor positions

Categories

(Firefox :: General, defect, major)

x86
macOS
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 644733

People

(Reporter: erik, Unassigned)

Details

Hold onto your hats; this is a crazy one:

1. Set up a side-by-side dual-monitor setup, and open Minefield.
2. Go into the Displays prefpane, and swap the locations of your monitors. Don't change which display the menubar is on.
3. Bring Minefield to the front (or restart it; it doesn't matter), drag a browser window to the secondary monitor, and make sure it's frontmost.
4. Try to make a new browser window by hitting command-N or choosing File->New Window.

Result: No window appears, though a new one is listed in the Windows menu.
This is happening without swapping monitor positions in 4.0b7.  Steps to reproduce:

1) Open Firefox 4.0b7.
2) Focus a window on a secondary display.
3) use [apple]+n or File->New Window.

Result:
A new window lists in the Windows menu, but it can not be selected.
The window seems to be opened with dimensions  0x0, if you try to close Firefox (with the open tabs warning enabled) the warning dialog opens.

On the next restart of Firefox, the window will be a very small 'slit' where the warning dialog was located.
FWIW, I can't reproduce this in 4.0b7 without swapping monitor positions. Also, I, too, have seen the "slit" behavior.
I am running Mac OS X 10.6.5 (10H574), on a MacBookPro6,2 (2.66 GHz i7, 8GB RAM) I have an external monitor that is connected as my 'primary' display (ie the display with the menubar).  Without swapping my monitor positions or disconnecting the external display, I get this issue.  It persists between shutdowns and reboots.

I get the issue _every time_ I create a new window when the active window is on the 'secondary' display.  From what I can tell it happens if the window is more than 50% on the secondary display.  My primary monitor is on the right.

What kind of information would be useful in tracking this down? I am not sure where to start.

Displays:
Color LCD:
  Resolution:	1680 x 1050
  Pixel Depth:	32-Bit Color (ARGB8888)
  Mirror:	Off
  Online:	Yes
  Built-In:	Yes
SyncMaster:
  Resolution:	1920 x 1080 @ 50 Hz
  Pixel Depth:	32-Bit Color (ARGB8888)
  Main Display:	Yes
  Mirror:	Off
  Online:	Yes
  Rotation:	Supported
  Television:	Yes
(In reply to comment #1)
> On the next restart of Firefox, the window will be a very small 'slit' where
> the warning dialog was located.

This is bug 609659. It would be helpful if you can chime in there with your exact steps to reproduce (bonus points if you can make it happen in a new profile).
(In reply to comment #4)
> (In reply to comment #1)
> > On the next restart of Firefox, the window will be a very small 'slit' where
> > the warning dialog was located.
> 
> This is bug 609659. It would be helpful if you can chime in there with your
> exact steps to reproduce (bonus points if you can make it happen in a new
> profile).

Actually, this is different from bug 609659. Bug 609659 claims that the new window is created although it's near invisible. This bug, however, claims that new window never gets created.

I've experience both bugs on my Mac. In bug 609659, you can Command+` to the other near invisible window. In this bug, Command+` doesn't do anything, indicating the new window doesn't get created.

I have near same set up as Robert Kluin.
I can reproduce it up to RC1.
Open two windows, one on the main display, one on a second (* see below regarding graphic cards) display. Select second display, press "new window" - and you see none. Nothing happens. But you can see a non selectable entry in the window menu - one for every new (invisible) window you create. Restarting Firefox let all the new windows appear - right there, on the second display.
Same with "open new window when clicking on a link" in a windows on the second display. Tabs do work though, just no new window.
I also had (with b12) a quite strange artefact with those invisible windows after a Firefox restart. I could close 3 of 5 of those new windows, 2 remain as a vertical line (but with shadow..) on the second display even after a second restart of Firefox. Selecting the line and pressing command-w to "close the lines" worked, the lines disappeard.
I have three displays attached to two NVidia cards. I have the problems on my left display, which is connected to the second NVidia. On the third display, attached to the same NVidia as the main display, all works fine.
Addition:
Error also in new fresh profile with only 2 empty windows, one on the main display, one on the left. And I saw again (after Firefox restart) those "1-line-windows" on the left display with RC1. Same behaviour, I could click on that vertical line and "close the line" with command-w.
I am seeing this as well with Firefox 4.0 final, and I think I discovered a critical detail when reproducing this.

I'm running on a MacBook Pro with an external display connected. I'll use "internal" and "external" to differentiate the physical displays. I then have the OS configured to have the external display as the "primary" display (the one with the menu bar and dock) which makes the internal display the "secondary" display. With that setup, I see this problem when a window on the internal ("secondary") display has focus.

I also tested with the internal display as the primary display. In that configuration, I do not see this problem, no matter which display the currently focused window is on. I did not test differences with the relative arrangement of the displays.

I suspect that this is not specific to laptops and that, even on a desktop system with 2 displays, there's an enumeration of the displays from the hardware perspective that does not necessarily line up with the OS-level concept of primary vs. secondary.
I am seeing the same behavior as Robert and Brian. I've run this down a tiny bit more. Details to reproduce (or fail to), on a MacBook Pro:

External display must be on the right (not left, above, or below)
External display must be primary (have the menu bar)
Window on secondary (internal) display must have focus
The bug manifests immediately after changing configuration--I don't even need to close the arrangement manager, or move the Firefox window.

This is *not* a dupe of bug 609659 as mentioned above (though the 'slit window' sounds related).
Firefox 4.0 final
My system is a 15" 2010 MBP, 2.66 Core 2 Duo, 8 GB RAM, OS 10.6.7, with a 24" Apple cinema display run directly via MiniDisplayPort.
If Firefox is restarted, sometimes some of the windows appear, sometimes they don't. When they do, they're usually a slit. Occasionally I can close them by selecting them from the Window menu and hitting Cmd+W, but usually not.
(In reply to comment #9)
> External display must be on the right (not left, above, or below)
> External display must be primary (have the menu bar)
> Window on secondary (internal) display must have focus

I still haven't tested relative arrangement of displays myself, but my external/primary display is to the right of my internal/secondary display, which is in line with Matt's findings.
(In reply to comment #10)
> (In reply to comment #9)
> > External display must be on the right (not left, above, or below)
> > External display must be primary (have the menu bar)
> > Window on secondary (internal) display must have focus
> 
> I still haven't tested relative arrangement of displays myself, but my
> external/primary display is to the right of my internal/secondary display,
> which is in line with Matt's findings.

Same here. My external/primary display is to the right of my internal/secondary display as well.
Observed this issue with the external display on the right side as well.
Hmm.. My MacPro "boots on the left display" I have the problems with, but the main display is the bigger one in the middle. Somehow simular to that setup with external display on a laptop.
NVIDIA GeForce 8800 GT:

  Chipset Model:	NVIDIA GeForce 8800 GT
  Type:	GPU
  Bus:	PCIe
  Slot:	Slot-4
  PCIe Lane Width:	x8
  VRAM (Total):	512 MB
  Vendor:	NVIDIA (0x10de)
  Device ID:	0x0602
  Revision ID:	0x00a2
  ROM Revision:	3233
  Displays:
Display Connector:
  Status:	No Display Connected
SyncMaster:
  Resolution:	1600 x 1200 @ 60 Hz
  Pixel Depth:	32-Bit Color (ARGB8888)
  Mirror:	Off
  Online:	Yes
  Rotation:	Supported

NVIDIA GeForce 8800 GT:

  Chipset Model:	NVIDIA GeForce 8800 GT
  Type:	GPU
  Bus:	PCIe
  Slot:	Slot-1
  PCIe Lane Width:	x16
  VRAM (Total):	512 MB
  Vendor:	NVIDIA (0x10de)
  Device ID:	0x0602
  Revision ID:	0x00a2
  ROM Revision:	3233
  Displays:
SyncMaster:
  Resolution:	1600 x 1200 @ 60 Hz
  Pixel Depth:	32-Bit Color (ARGB8888)
  Mirror:	Off
  Online:	Yes
  Rotation:	Supported
SyncMaster:
  Resolution:	1920 x 1200 @ 60 Hz
  Pixel Depth:	32-Bit Color (ARGB8888)
  Main Display:	Yes
  Mirror:	Off
  Online:	Yes
  Rotation:	Supported
  Television:	Yes
(In reply to comment #9)
> External display must be on the right (not left, above, or below)
> External display must be primary (have the menu bar)
> Window on secondary (internal) display must have focus
> The bug manifests immediately after changing configuration--I don't even need
> to close the arrangement manager, or move the Firefox window.

Just noticed that, under the same circumstances, if you download something the Download Manager doesn't open (though it does appear in the Window menu, same as attempted new windows). So, this might be a somewhat more general window-spawning issue.
Sadly my external display is on the left, not the right. I'm seeing this in FF 4.0 Final as well. I've dropped back to 3.6.15 until this one is fixed.
Found another annoyance. Moving a tab to the desktop (to create a new window) also does not work when the tab's parent window is on the troubled display. The tab disappears and the newly created window is gone - but has an entry in the window menue (which isn't working also). Selecting the menue entry doesn't change focus, just nothing. Restarting Firefox worked again - though this time the re-appeared new windows was again nothing but a thin vertikal line. This picture shows the thin line on the left and a window on the right how it should be (same URL):
http://www.zeitkind.com/vertical-line-bug.png
Selecting the "dead entry" in window menue switches focus to the "line-window", the line gets shadowed. Closing with command-w works.
(In reply to comment #16)

> change focus, just nothing. Restarting Firefox worked again - though this time
> the re-appeared new windows was again nothing but a thin vertikal line.

I see the drag-to-desktop failure too. Though, once restarted, if you're really accurate with the mouse at the lower tip of the line-window it can be re-sized to show the page.
Update:  The bug went away when I was connected to a different monitor (an old Mitsubishi 17" LCD); came back when I reconnected my usual monitor (see comment above).  Same configuration otherwise (MBP as secondary, external as primary on right side of the MBP).

Occurred with FF 4.0.
Reproduced in firefox-4.2a1pre.en-US, with additional information:
I ran four tests, changing the Primary Monitor and whether the External Monitor is on the Right or the Left.
The results are that the new window does not appear only when
	A) the external monitor is the primary monitor (i.e. displays the menus and the dock)
	B) the external monitor is to the Right of the built-in monitor

Furthermore, in this problem situation, the non-appearing window is listed in the Window menu, but it cannot be selected. When Firefox is restarted, the window initially appears as a thin vertical line, and it can be selected and zoomed to a normal window.

Details:
Reproduced in firefox-4.2a1pre.en-US, in a profile with no added extensions.

Monitor Configuration:
Two Monitors
- External 20" resolution is 1600x1200.
- Built-in MacBook Pro 15 1/2" resolution is 1440x852.

Set Preferences>General>When Firefox starts: Show my windows and tabs from last time

I. Monitor Arrangement:
	A) the external monitor is the primary monitor (i.e. displays the menus and the dock)
	B) the external monitor is to the Right of the built-in monitor

1. Start Firefox
2. Position the initial browser window on the secondary monitor
3. File>New Window
*Result: No new window appears. However, the Window menu lists 2 windows. Selecting the second window does nothing: the checkmark remains next to the first window.

4. Quit and re-Start Firefox
*Result: The first window appears on the secondary monitor. Also, there is also a single vertical line on the secondary monitor. Two windows appear in the Window menu.

5. Select the second window in the Window menu.
*Result: The vertical line to becomes the frontmost window.

6. Window>Zoom
*Result: The vertical line expands to a full window.

7. Window>Zoom
*Result: The full window becomes a tall, thin window, approximately 40 pixels wide.


II. Monitor Arrangement:
	A) the built-in monitor is the primary monitor
	B) the external monitor is to the Right of the built-in monitor

1. Start Firefox
2. Position the initial browser window on the secondary monitor
3. File>New Window
*Result: The second browser window appears correctly.


III. Monitor Arrangement:
	A) the external monitor is the primary monitor
	B) the external monitor is to the Left of the built-in monitor
1. Start Firefox
2. Position the initial browser window on the secondary monitor
3. File>New Window
*Result: The second browser window appears correctly.


IV. Monitor Arrangement:
	A) the built-in monitor is the primary monitor
	B) the external monitor is to the Left of the built-in monitor

1. Start Firefox
2. Position the initial browser window on the secondary monitor
3. File>New Window
*Result: The second browser window appears correctly.
Bug is still present on FF 5.0.
Bug stil present in FF 5.0 on Mac OS X 10.5.8.
A new windows open correctly when there is an existing Firefox window on the 'main' screen (one with menu bar) and I Apple-N/File->New Window.
Windows do not open when the Firefox window is on the secondary screen.

I can drag the Firefox window between primary and secondary screen.
When it is on the main screen, Firefox creates a new visible window.
When the firefox window ison the secondary screen, the new window is invisible.
It does not matter if there are other Firefox windows on the primary screen, it only matters which Firefox window has foxuws when I try to create the new window.
Bug still present in FF 6.0 on Mac OS X 10.6.8.
I am having the same problem but my "external" monitor is on the left. (Firefox 6.0 Mac OS 10.7 iMac)

The menu bar is on the actual iMac screen. I usually have a few windows open on each screen. When I get too many tabs across, I right-click to the contextual menu and choose "Move to New Window" and then I get nothing at all (and yet I can still hear whatever audio was running on that page) OR if I go to the menu bar and drag down to select New Window (command New) then I get the 1 pixel wide page others have experienced.

My most common remedy is to restart Firefox and then all the missing and/or new pages open and display as expected. Anyone find a better remedy?
I switched to Chrome as my primary browser.  It sucked for the first few days since I've been using FireFox, or its predecessors for 10 years, but after a couple weeks I didn't mind that much.  I still use FireFox for occasional browsing and testing.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 644733
You need to log in before you can comment on or make changes to this bug.