Closed Bug 609443 Opened 9 years ago Closed 9 years ago

Jumplist entries not shown after clean (re-)install

Categories

(Firefox :: Shell Integration, defect, major)

x86
Windows 7
defect
Not set
major

Tracking

()

RESOLVED INVALID

People

(Reporter: c.ascheberg, Unassigned)

Details

(Keywords: regression)

User-Agent:       Mozilla/5.0 (Windows NT 6.0; rv:2.0b8pre) Gecko/20101103 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (Windows NT 6.0; rv:2.0b8pre) Gecko/20101103 Firefox/4.0b8pre

Minefield does not show jumplist entries after a clean (re-)install.
Restarting Minefield has no effect, but it works after having entered private browsing mode once.

It (partly / buggy) worked in
2010-10-13-04-mozilla-central f6e81dd5a12
and it is completely broken in
2010-10-14-04-mozilla-central ad0a0be8be74

Reproducible: Always

Steps to Reproduce:
0. uninstall Minefield and remove personal data
1. (re-)install Minefield
2. open Minefield
3. right click Minefield in taskbar
Actual Results:  
only basic entries are shown, no advanced jumplist entries

Expected Results:  
"Tasks" like "Enter private browsing" etc. should also be shown
blocking2.0: --- → ?
Keywords: regression
Version: unspecified → Trunk
oops I guess it is related to bug 598229 and it just takes some time before those entries are created, so closing this already...
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → INVALID
(In reply to comment #1)
> oops I guess it is related to bug 598229 and it just takes some time before
> those entries are created, so closing this already...

yes, this was a startup perf problem, so we delayed the refresh for about 30 seconds.
blocking2.0: ? → ---
(In reply to comment #2)
> we delayed the refresh for about 30 seconds

(It seems to be 120 seconds)

Well, actually I still think that it would just look a bit nicer to at least show the jumplist items for tasks immediately and thus showing the user that there is some kind of functionality, even in the case that the user clicks the taskbar shortly after installation.
I guess there is not that much calculation needed for the tasks part, compared to the "Frequent" part? Or maybe it could be solved nicely by adding a default status to the clean profile?
You need to log in before you can comment on or make changes to this bug.