Last Comment Bug 609588 - Remove all cookies button is disabled in search results
: Remove all cookies button is disabled in search results
Status: RESOLVED FIXED
[4b7]
:
Product: Firefox
Classification: Client Software
Component: Preferences (show other bugs)
: Trunk
: x86 All
: -- normal (vote)
: Firefox 13
Assigned To: Nobody; OK to take it and work on it
:
: Jared Wein [:jaws] (please needinfo? me)
Mentors:
Depends on: 705422
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-04 06:15 PDT by Srinivas
Modified: 2012-03-07 16:47 PST (History)
12 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-


Attachments

Description Srinivas 2010-11-04 06:15:55 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/534.7 (KHTML, like Gecko) Chrome/7.0.517.41 Safari/534.7
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b8pre) Gecko/20101101 Firefox/4.0b8pre

unable to remove all the cookies displayed while searching for a particular domain

Reproducible: Always

Steps to Reproduce:
1.Open firefox and browse a site,for ex:facebook
2.Open Tools->Options->Privacy,click on the link "remove individual cookies"
3.In Cookies dialog: search for facebook
4.results are displayed showing cookies for facebook
Actual Results:  
the button "Remove all cookies" is disabled
Comment 1 Jim Jeffery not reading bug-mail 1/2/11 2010-11-04 06:19:32 PDT
Confirmed - using today's nightly build using cset:
http://hg.mozilla.org/mozilla-central/rev/f7016571b472
Comment 2 Jim Jeffery not reading bug-mail 1/2/11 2010-11-04 06:49:44 PDT
I have tested builds back to first part of July and still not found where this went broke.  

Has it ever worked I wonder ?
Comment 3 Ken 2010-11-04 07:41:24 PDT
(In reply to comment #2)
> I have tested builds back to first part of July and still not found where this
> went broke.  
> 
> Has it ever worked I wonder ?

If you Select a Group of cookies (ex: click on the '2o7.net' cookies folder) the 'Remove all cookies' button will light up (tested with Firefox 4.0 beta 6 & Firefox 3.6.12), but if you make the mistake thinking it will delete the selected cookies, and press the button it will remove ALL your cookies not just the selected cookies.

If you select multiple cookies (not just search for them) then press the 'Delete' key on your keyboard, you will only delete what was selected.
Comment 4 Luke Iliffe (Harlequin99) 2010-11-04 08:59:41 PDT
Is this behaviour different in ff 3.6.x?
Comment 5 Srinivas 2010-11-04 09:35:25 PDT
Build identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.3) Gecko/20091020 Ubuntu/9.10 (karmic) Firefox/3.5.3

Not working with above build also.
Comment 6 [not reading bugmail] 2010-11-04 20:23:37 PDT
I'm not surprised that to me is the expectation.  Having Remove All cookies is disabled after filtering a search makes sense, because remove all cookies actually removes all cookies, not just 1 cookie domain folder found in a search.  How about using remove cookies.. does that work like the delete key?  I just wiped out all mine. doh
Comment 7 [not reading bugmail] 2010-11-04 20:32:11 PDT
This is not a regression.  3.5 branch works the same way, this is a enhancement request.  

I wouldn't expect 'Remove all cookies' to be enabled with filtering search results, as 'remove cookies' works like its suppose to with filtered search results.  

I would this should be wontfix.
Comment 8 Ken 2010-11-05 00:48:26 PDT
(In reply to comment #7)
> ... this is a enhancement request.  
> 
> I wouldn't expect 'Remove all cookies' to be enabled with filtering search
> results, as 'remove cookies' works like its suppose to with filtered search
> results.  

If remove all cookies wipes everything out (like happened to you in Comment #6) shouldn't selecting cookies (clicking on them), also turn off the 'Remove all cookies' button, just like after doing a search for them does?

And/or, since the link Tile (comment #0) is "remove individual cookies" could there be a warning asking something like 'Do you want to remove Every cookie? Doing this will...', or Hover over text for the Button saying something similar?
Comment 9 Emil Ivanov 2010-11-05 17:07:20 PDT
If you want to delete all filtered cookies you can select one and just press and hold delete key until the list is cleared...
Comment 10 Emil Ivanov 2010-11-05 17:08:12 PDT
Ops sorry didnt mean to remove anything....
Comment 11 Dietrich Ayala (:dietrich) 2010-11-08 09:29:01 PST
Comment #7 is correct, this is expected behavior, so that you don't delete all your cookies while viewing a subset of them. Blocking-.

Not closing this bug though - I recommend you repurpose it to clarify the interaction (or at least the string).
Comment 12 Christian Sonne [:cers] 2011-10-20 12:22:02 PDT
I think if "select all" Ctrl+A (Cmd+A) worked, this would be much less of an issue. Unfortunately, it doesn't do anything when in search results.
Comment 13 Christian Sonne [:cers] 2012-03-07 16:45:03 PST
This bug was fixed by bug 705422.

Note You need to log in before you can comment on or make changes to this bug.