Closed Bug 609668 Opened 12 years ago Closed 12 years ago

Regression of Bug 549617: JSD doesn't see variables in flat closure

Categories

(Core :: JavaScript Engine, defect)

x86
Windows Vista
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: Honza, Unassigned)

Details

(Whiteboard: [firebug-p1])

STR:

1) Install Firebug from: http://www.softwareishard.com/temp/firebug-1.7X.0a4.608763.xpi
2) Load http://getfirebug.com/tests/content/script/2871/issue2871.html
3) Follow instructions on the page

This is regression of Bug 549617 - JS_EvaluateUCInStackFrame doesn't see variables in flat closure

Some more information about this problem (compare with other browsers):
http://www.sroussey.com/article/2010/10/25/44165/Debugging-Closures

The original Firebug report is here:
http://code.google.com/p/fbug/issues/detail?id=2871

Honza
Whiteboard: [firebug-p1]
I have retested the original Firebug issue report and works for me now!
Closing.
Honza
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.