Closed Bug 609717 Opened 10 years ago Closed 10 years ago

Do not fail tagging if APPROVAL_REQUIRED is commented out on the tinderbox page status

Categories

(Release Engineering :: General, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 589914

People

(Reporter: armenzg, Unassigned)

References

Details

For beta7 I had change the status of the tree to CLOSED and commented out with HTML comments the previous APPROVAL_REQUIRED message.

This caused the tagging job to fail as it found APPROVAL_REQUIRED even if it was commented out.

We should not fail if CLOSED appears at the same time as APPROVAL_REQUIRED.

Reference code:
http://hg.mozilla.org/hgcustom/hghooks/file/tip/mozhghooks/treeclosure.py#l59
Is this a bug on the hghooks, or the tagging code?
Well, we could fix tagging to have "a=" in it.
(In reply to comment #2)
> Well, we could fix tagging to have "a=" in it.
>
In the comment.
Definitely a dupe - and really, we shouldn't do the comment out thing afaic I think we should go the extra mile and remove APPROVAL REQUIRED, then put it back when done. It's not worth the risk of messing with that hook code and the hook code is good for developers' tree management.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 589914
(In reply to comment #5)
> Definitely a dupe - and really, we shouldn't do the comment out thing afaic I
> think we should go the extra mile and remove APPROVAL REQUIRED, then put it
> back when done. It's not worth the risk of messing with that hook code and the
> hook code is good for developers' tree management.

When bug 508896 is fixed, we won't be closing the tree to tag, and we will need to have the a= in the comment to tag the tree anyway.
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.