Form helper makes commenting on tor.com impossible

VERIFIED FIXED

Status

Firefox for Android Graveyard
General
VERIFIED FIXED
8 years ago
7 years ago

People

(Reporter: jdm, Assigned: vingtetun)

Tracking

Trunk
ARM
Android

Details

Attachments

(1 attachment, 1 obsolete attachment)

Comment hidden (empty)
(Reporter)

Updated

8 years ago
Summary: Form helper makes commenting on tor → Form helper makes commenting on tor.com impossible
(Reporter)

Comment 1

8 years ago
It zooms away from the comment box every time you press a cjaracter.
Vivien - was this fixed by of the form helper zooming patches?
Assignee: nobody → 21
tracking-fennec: --- → 2.0b3+
(Reporter)

Comment 3

8 years ago
I saw this behaviour on today's nightly on my Galaxy S, if it's any help.
I'm not sure of what's happening right now, I'm trying to reduce tor.com to a usable testcase for the moment.
This bug is 2 bugs, the "zooms away" will be fixed by bug 479862, the jumps happen because the view position and content position are not synced.
If I forced them to be synced there is no jump when clicking.

There is a second bug thought, since the Form Helper is not showing at all for the comments box, it looks like Form Helper does not handle contentEditable!
I will fix the later in this bug.
Depends on: 479862
Created attachment 488833 [details] [diff] [review]
Patch

This patch does not show the Form Helper UI, I don't think this make sense with contentEditable field, so the solution I proposed is to just zoom to the element.

I would like Madhava to confirm this is something we may want.
Madhava,
can I have your opinion on the last comment I've made? thanks.
Created attachment 490876 [details] [diff] [review]
Patch v0.2

This patch show the FormHelper when needed (it does not resolve the first jump which will be fixed by an other bug as said in a previous comment)
Attachment #488833 - Attachment is obsolete: true
Attachment #490876 - Flags: review?(mark.finkle)
Attachment #490876 - Flags: review?(mark.finkle) → review+
Duplicate of this bug: 573447
http://hg.mozilla.org/mobile-browser/rev/7df5f19f8997
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Comment 11

7 years ago
This bug is VERIFIED FIXED since the form helper feature was dropped off.

Build Id: Mozilla /5.0 (Android;Linux armv7l;rv:7.0a1) Gecko/20110608 Firefox/7.0a1 Fennec/7.0a1 

Device: HTC Desire Z (Android 2.2)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.