Closed Bug 609730 Opened 11 years ago Closed 10 years ago

Sync set up dialog has a run-on sentence: "Welcome, if you've never used Firefox Sync before, you will need to create a new account."

Categories

(Firefox :: Sync, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED
mozilla11
Tracking Status
blocking2.0 --- -

People

(Reporter: dholbert, Assigned: nigelb)

References

Details

(Keywords: uiwanted, Whiteboard: [good first bug][verified in services][qa!])

Attachments

(4 files, 1 obsolete file)

Attached image screenshot
STEPS TO REPRODUCE:
In a fresh profile, go to "sync" tab in Firefox Preferences, and click "Set Up Firefox Sync"

The dialog shown at that point says:

"Welcome, if you've never used Firefox Sync before, you will need to create a new account."

That sentence is grammatically incorrect. A comma is the wrong form of punctuation to have after "Welcome". Right now it almost sounds like we're only welcoming those people who've never used Firefox Sync before. :)

I think we want "Welcome!" or "Welcome;" or "Welcome --"
Fixing this would technically be a string change, but since it's only punctuation and not content, I'm hoping it might be a no-l10n-updates-needed type of string change.
blocking2.0: --- → ?
OS: Linux → All
Hardware: x86_64 → All
Whiteboard: [strings]
I had it as "Welcome!" in one of the original revs but Faaborg made me change it to "Welcome," as per his mockups (bug 589980). CCing him for input.
Whiteboard: [strings] → [strings?]
I don't really remember making the change, so I think what happened was I probably introduced the error in my mockup.  (possibly I was interested in toning down the enthusiasm of the exclamation point and ended up creating the run on sentence at the same time).  We can change it back to "Welcome!" if we can get the string change in.
Duplicate of this bug: 611337
Given that we're past string-freeze now, blocking-. I think the path to take would be to get this patched and ask for approval.
blocking2.0: ? → -
Keywords: late-l10n
Whiteboard: [strings?] → [strings?][good first bug]
Comment on attachment 491776 [details] [diff] [review]
back to !

Should definitely run this by Axel first whether or not we need to bump the entity, since it's only a punctuation change.
Attachment #491776 - Flags: feedback?(l10n)
Looking through http://mxr.mozilla.org/l10n-central/search?string=setup.pickSetupType&find=syncSetup.dtd, it's borderline. Many locales kept the structure, asking for more input.

Among others, Kadir, I see you used the ! already, is that fixing the same grammar bug? Do you know if that spreads into other (germanic) languages?
Yeah, I'd say it's probably the same for most languages with an imperative form of the word and a punctuation mark.
Comment on attachment 491776 [details] [diff] [review]
back to !

In that case, I'm leaning towards entity change.
Attachment #491776 - Flags: feedback?(l10n) → feedback-
Let's just change the entity, and fix this however we feel is best.  Faaborg: string suggestion?
Assignee: nobody → ally
Keywords: late-l10nuiwanted
Whiteboard: [strings?][good first bug] → [good first bug]
What needs to happen here? String change and entity change?
Assignee: ally → nigelbabu
Status: NEW → ASSIGNED
(In reply to Nigel Babu [:nigelb] from comment #12)
> What needs to happen here? String change and entity change?

Yip
(In reply to Mike Connor [:mconnor] from comment #11)
> Let's just change the entity, and fix this however we feel is best. 
> Faaborg: string suggestion?

Strawman suggestion for string-change: "Welcome, if" --> "Welcome! If"  (from comment 0)
Attached patch patch-v1 (obsolete) — Splinter Review
Changes the string and appropriate entity change.
Attachment #577343 - Flags: review?(ally)
Comment on attachment 577343 [details] [diff] [review]
patch-v1

Review of attachment 577343 [details] [diff] [review]:
-----------------------------------------------------------------

looks functionally & grammatically correct to me.

nigelb, please attach a screen shot when you get a chance
Attachment #577343 - Flags: review?(mconnor)
Attachment #577343 - Flags: review?(ally)
Attachment #577343 - Flags: feedback+
Attachment #577343 - Flags: review?(mconnor) → review+
Attached patch patch-r+Splinter Review
Attachment #577343 - Attachment is obsolete: true
Whiteboard: [good first bug] → [good first bug][checkin-needed]
nigelb, congrats. \o/

tip: next time, please dont obsolete the patch with the r+ on it. It confuses people who would otherwise be happy to land your patch because it looks like you code is missing review. :)
Pushed:

https://hg.mozilla.org/services/services-central/rev/9dc80d92e1f3

Thanks for the patch, Nigel!
Whiteboard: [good first bug][checkin-needed] → [good first bug][fixed in services]
Steps to test: On a profile without sync setup, go to Tools -> Setup Sync.  The text should be right below the Firefox Sync title of the dialog.
Whiteboard: [good first bug][fixed in services] → [good first bug][fixed in services][qa+]
Attached image new-screenshot
Mozilla/5.0 (Windows NT 6.1; rv:11.0a1) Gecko/20111205 Firefox/11.0a1
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:11.0a1) Gecko/20111205 Firefox/11.0a1
Mozilla/5.0 (X11; Linux i686; rv:11.0a1) Gecko/20111205 Firefox/11.0a1

Verified using the above builds - correct message is displayed at Sync setup, i.e.: "Welcome! If you've never used Firefox Sync before, you will need to create a new account." (as in the screenshot from comment #21)
Whiteboard: [good first bug][fixed in services][qa+] → [good first bug][verified in services][qa+]
Pushed to m-c: https://hg.mozilla.org/mozilla-central/rev/9dc80d92e1f3
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla11
verified on m-c builds of 20111223
Status: RESOLVED → VERIFIED
Whiteboard: [good first bug][verified in services][qa+] → [good first bug][verified in services][qa!]
Component: Firefox Sync: UI → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.