Closed Bug 609757 Opened 11 years ago Closed 11 years ago

table-cell height calculation uses border-box sizing; should use content-box

Categories

(Core :: Layout: Tables, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 295315

People

(Reporter: folkyvolk, Unassigned)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US) AppleWebKit/534.11 SUSE/9.0.569.0 (KHTML, like Gecko) Chrome/9.0.569.0 Safari/534.11
Build Identifier: 3.6.8

The example:

The width of the TD will become 50px but the height only 22px, because Firefox seems to do something like the "old IE box model" for the height, ie

border-top + padding-top + height + padding-bottom + border-bottom = 50px
in this example.

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN">
<html>
  <head>
    <title>tdheight.html</title>
    <style>
      td {
        border: 10px solid black;
        padding: 4px;
        width: 50px;
        height: 50px;
      }
    </style>
  </head>
  <body>
    <table>
      <tr>
        <td>x</td>
      </tr>
    </table>
  </body>
</html>

Reproducible: Always



Expected Results:  
border and padding should be added to the height, height should behave same as width.
Attached file The testcase
Yeah, I'm not sure why we end up with border-box y sizing.  Bernd?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Blocks: css2.1-tests
Summary: Firefox gets it wrong when calculating height for explicitly sized table cells → table-cell height calculation uses border-box sizing; should use content-box
Isn't this a dupe of bug 295315
yeah; its summary didn't have any of the things I was searching for, though.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 295315
No longer blocks: css2.1-tests
You need to log in before you can comment on or make changes to this bug.