Persona theme overlap caption buttons when opening a new browser window and parent window is maximized

RESOLVED FIXED in mozilla2.0b9

Status

()

Core
Widget: Win32
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: Eddward, Assigned: Felipe)

Tracking

unspecified
mozilla2.0b9
x86
Windows 7
Points:
---

Firefox Tracking Flags

(blocking2.0 final+)

Details

(Whiteboard: [4b7], URL)

Attachments

(3 attachments)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b7) Gecko/20100101 Firefox/4.0b7
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b7) Gecko/20100101 Firefox/4.0b7

This problem appears only when I have Firefox in maximized mode.


Reproducible: Always

Steps to Reproduce:
1. enable persona theme
2. go to http://www.pageresource.com/jscript/jwinopen.htm and click on New Window! button under "A New Browser Window" title.
3. persona theme overlaps caption buttons

Actual Results:  
http://img143.imageshack.us/img143/9149/newwindow.jpg

Expected Results:  
http://img810.imageshack.us/img810/8531/nwwl.jpg

Updated

7 years ago
Component: Theme → Widget: Win32
Product: Firefox → Core
QA Contact: theme → win32
Whiteboard: [4b7]
I don't see this using Mozilla/5.0 (Windows NT 5.1; rv:2.0b7) Gecko/20100101 Firefox/4.0b7. Will try on a Win XP machine.

Comment 2

7 years ago
Created attachment 488922 [details]
Another Instance

In my case (FF4b6 with the "Sunset Over Water" persona), all the controls are now invisible but this is not easily reproducible. See attachment.
(Assignee)

Comment 3

7 years ago
It's not directly related to the personas theme. It seems that this kind of popup window only get wrong dimensions for the titlebar top padding (as if it was a maximized window). Interesting that it only happens when the parent window is maximized.

Comment 4

7 years ago
(In reply to comment #2)
> Created attachment 488922 [details]
> Another Instance
> 
> In my case (FF4b6 with the "Sunset Over Water" persona), all the controls are
> now invisible but this is not easily reproducible. See attachment.

That's bug 545892.

Comment 5

7 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b7) Gecko/20100101
> Firefox/4.0b7
> Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b7) Gecko/20100101
> Firefox/4.0b7
> 
> This problem appears only when I have Firefox in maximized mode.
> 
> 
> Reproducible: Always
> 
> Steps to Reproduce:
> 1. enable persona theme
> 2. go to http://www.pageresource.com/jscript/jwinopen.htm and click on New
> Window! button under "A New Browser Window" title.
> 3. persona theme overlaps caption buttons
> 
> Actual Results:  
> http://img143.imageshack.us/img143/9149/newwindow.jpg
> 
> Expected Results:  
> http://img810.imageshack.us/img810/8531/nwwl.jpg

I'm not seeing this either. We had a lot of problem with the fx button showing up on popups, but those were all fixed a long time ago. This looks like one of those bugs, but B7 shouldn't have any of these issues.
(Reporter)

Comment 6

7 years ago
With new profile and latest nightly beta8pre I have the same (bad)results...
DW,D2D,D3D10 on
OS: Win 7 with aero enabled
(Assignee)

Comment 7

7 years ago
Created attachment 488997 [details]
Testcase

Simple testcase.

I still can see it with current nightly.

Comment 8

7 years ago
(In reply to comment #7)
> Created attachment 488997 [details]
> Testcase
> 
> Simple testcase.
> 
> I still can see it with current nightly.

Confirmed, sorta, first time it happened. Subsequent times it doesn't. Very strange.

Comment 9

7 years ago
(In reply to comment #8)
> (In reply to comment #7)
> > Created attachment 488997 [details] [details]
> > Testcase
> > 
> > Simple testcase.
> > 
> > I still can see it with current nightly.
> 
> Confirmed, sorta, first time it happened. Subsequent times it doesn't. Very
> strange.

sorry, forgot the base window needs to be maxed. confirmed, I see this ever time.
(Assignee)

Comment 10

7 years ago
Ok good, then it's not just me. It seems that 
#main-window[sizemode="maximized"] matches this window
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

7 years ago
Duplicate of this bug: 614148
(Assignee)

Updated

7 years ago
blocking2.0: --- → ?
Summary: Persona theme overlap caption buttons when opening a new browser window → Persona theme overlap caption buttons when opening a new browser window and parent window is maximized

Updated

7 years ago
Depends on: 575725
Assignee: nobody → felipc
blocking2.0: ? → final+
(Assignee)

Updated

7 years ago
Duplicate of this bug: 575725
(Assignee)

Comment 13

7 years ago
Created attachment 498466 [details] [diff] [review]
Patch

The sizemode attribute is only set on windows that have set sizemode to persist. Popup windows that are also browser.xul do not persist those, and so the attribute itself is not set properly.

Another alternative would be to set the sizemode to persist for these windows, but I don't know what are the reasons for it being currently not set (it's plausible that we don't want popup window attributes to override the regular window settings), but this approach seems safer and innocuous.
Attachment #498466 - Flags: review?(neil)
Comment on attachment 498466 [details] [diff] [review]
Patch

Originally I think the idea was to avoid setting attributes that nobody used.

>+      if (ownerXULDoc &&
>+		  persistString.Find("sizemode") >= 0)
Some tabs crept in here, although you might as well put this all on one line as it's only 55 characters (61 if you include indentation).
Attachment #498466 - Flags: review?(neil) → review+
(Assignee)

Comment 15

7 years ago
http://hg.mozilla.org/mozilla-central/rev/34f521036d9d
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b9
You need to log in before you can comment on or make changes to this bug.