Last Comment Bug 610075 - Nightly Firefox 3.5 builds offered current build as update even when current
: Nightly Firefox 3.5 builds offered current build as update even when current
Status: RESOLVED FIXED
[mozmill]
: regression
Product: Toolkit
Classification: Components
Component: Application Update (show other bugs)
: 1.9.1 Branch
: All Mac OS X
-- normal (vote)
: ---
Assigned To: Robert Strong [:rstrong] (use needinfo to contact me)
:
: Robert Strong [:rstrong] (use needinfo to contact me)
Mentors:
Depends on:
Blocks: 552924
  Show dependency treegraph
 
Reported: 2010-11-05 17:43 PDT by Al Billings [:abillings]
Modified: 2010-11-07 15:14 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
.16+
.16-fixed


Attachments

Description User image Al Billings [:abillings] 2010-11-05 17:43:45 PDT
It was noticed today that if you do a manual check for updates in a current 1.9.1 nightly build, you will be offered an update to "3.5.16pre". This update will be the same build as you already have.

I'm running Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.16pre) Gecko/20101105 Shiretoko/3.5.16pre and I keep getting offered a new build if I manually check and it is the same build after I restart for the update. 

The culprit may be the checkin two days ago into the 1.9.1 update code but I'm not sure. See http://hg.mozilla.org/releases/mozilla-1.9.1/rev/d16805f53fa1. 

Logging this under RelEng as requested by John O'Duinn.
Comment 1 User image Henrik Skupin (:whimboo) [away 02/18 - 02/27] 2010-11-05 17:46:48 PDT
Could that be happening because of the following patch which has been landed on 1.9.1 and now quits earlier with a JS error: "abi" not defined?

http://hg.mozilla.org/releases/mozilla-1.9.1/rev/d16805f53fa1
Comment 2 User image Henrik Skupin (:whimboo) [away 02/18 - 02/27] 2010-11-05 18:03:25 PDT
Fixing this broken check-in solved the problem for me and no more update is listed. So it's clearly a regression from bug 552924.

Adding Mozmill whiteboard entry because we detected this with our Mozmill test-runs.
Comment 3 User image Henrik Skupin (:whimboo) [away 02/18 - 02/27] 2010-11-05 18:16:42 PDT
The follow-up patch which has been landed on bug 552924, didn't fix the problem for me gAbi is still undefined:

Error: reference to undefined property "gAbi"
Source File: file:///Applications/Shiretoko.app/Contents/MacOS/components/nsUpdateService.js
Line: 1155
Comment 4 User image Robert Strong [:rstrong] (use needinfo to contact me) 2010-11-05 18:19:24 PDT
If you manually added that I would expect that error. It should be gABI which is what landed.
Comment 5 User image Henrik Skupin (:whimboo) [away 02/18 - 02/27] 2010-11-05 19:01:06 PDT
Gotcha! That's it. Now it's working fine. Thanks Rob!

Fixed with:
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/24b02f04fb6d
Comment 6 User image Henrik Skupin (:whimboo) [away 02/18 - 02/27] 2010-11-07 11:43:46 PST
As Al discovered we also have to push this fix to 1.9.2.
Comment 7 User image Henrik Skupin (:whimboo) [away 02/18 - 02/27] 2010-11-07 15:14:32 PST
On 1.9.2 it's not a problem with this patch. Nick was able to fix the update problem server-side. So no need for this patch on 1.9.2, even it would be useless, because there is nothing to fix.

Note You need to log in before you can comment on or make changes to this bug.