If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

details from the Japanese Patent Office would not load

RESOLVED DUPLICATE of bug 607573

Status

()

Core
HTML: Parser
--
major
RESOLVED DUPLICATE of bug 607573
7 years ago
7 years ago

People

(Reporter: Dan Nolan, Unassigned)

Tracking

({testcase})

Trunk
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; GTB6.6; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C)
Build Identifier: unable to provide - uninstalled firefox 4 beta

In firefox 4, details from the Japanese Patent Office would not load - removed 4, reinstalled 3.6, everything copacetic.

Reproducible: Always

Steps to Reproduce:
1. go to http://www19.ipdl.inpit.go.jp/PA1/cgi-bin/PA1DETAIL
2. press "Detail"
3. Result screen is blank in firefox 4, filled in 3.6
Actual Results:  
page is blank

Expected Results:  
[JP,2007-283121,A]
CLAIMS DETAILED DESCRIPTION TECHNICAL FIELD PRIOR ART TECHNICAL PROBLEM MEANS DESCRIPTION OF DRAWINGS DRAWINGS
[Translation done.]

Comment 1

7 years ago
Where is "Detail" link(button)?

The page shows as follows:

Searching PAJ information. A server gets crowded right now. Connect it after waiting for a while.
status : 4063
MENU
(Reporter)

Comment 2

7 years ago
Apparently, when entering the PAJ (Jap. patent off.) for the 1st time, you need to go through the lead-in menu to set up cookies or whatever - which I did long ago.  From the screen you describe or http://www.ipdl.inpit.go.jp/homepg_e.ipdl, select "PAJ" in the left column (4 down) and work through the subsequent search.  You can easily put in a simple search, like entering "replacement hip" (no quote) and selecting the resulting "index" button when the 2 dozen-or-so appear, then selecting one of them.  The problem that renders Firefox 4 unacceptable is that selecting the "detail" returns blank pages, whereas firefox 3.5 provides full info.

Comment 3

7 years ago
>You can easily put in a simple search, like entering "replacement hip" (no quote)
There are many input fields(6 fields). Where should I input the words and phrases into?

Comment 4

7 years ago
Created attachment 488660 [details]
screenshot

Is it this procedure as the attached screenshot? 
I do not seem to have any problem.

http://hg.mozilla.org/mozilla-central/rev/2b612890113b
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.13) Gecko/20101102 Firefox/4.0b8pre ID:20101106042135

Comment 5

7 years ago
Confirmed.

OK, 
After Step 6 in attachment 488660 [details],
I need click "DETAIL" pink button at the top of page.

If I set  html5.enable to false, the problem does not occur.

Google Chrome 7.0.517.44 also does not work.
Component: General → HTML: Parser
Product: Firefox → Core
QA Contact: general → parser

Updated

7 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Created attachment 488667 [details]
Raw copy of the problem page
Created attachment 488668 [details]
Testcase #1
Created attachment 488669 [details]
Testcase #2

Same as Testcase #1, but with the <input> removed.
http://www.whatwg.org/specs/web-apps/current-work/multipage/tokenization.html#the-after-head-insertion-mode
when seeing <form> we do to the "Anything else" in the "after head"
insertion mode which consumes everything up until <frameset> -
when there's an <input> (Testcase #1) the frameset-ok flag will be
"not ok" otherwise (Testcase #2) it will be "ok".

The clause for <frameset> in the "in body" insertion mode says:
http://www.whatwg.org/specs/web-apps/current-work/multipage/tokenization.html#parsing-main-inbody
"If the frameset-ok flag is set to "not ok", ignore the token.
Otherwise," ... "4. Switch the insertion mode to 'in frameset'"

So the parsing looks correct to me.
Keywords: testcase
Whiteboard: INVALID?
(Reporter)

Comment 10

7 years ago
you only need a few patents to choose one from - so put the words 
REPLACEMENT HIP
in the first field & hit "search" at the bottom, 
when the screen results return, then hit "index indication" at the top
and click on any patent
and, when the patent appears, 
hit the pink "DETAIL" at the top of the page to see a translated patent, 
or hit "JAPANESE" to see the original.

This "Detail" is what returns a blank page in Firefox 4.  With Firefox 3, an elaborate screen of claims, details, drawings, etc. in English is returned.
(Reporter)

Comment 11

7 years ago
you only need a few patents to choose one from - so put the words 
REPLACEMENT HIP
in the first field & hit "search" at the bottom, 
when the screen results return, then hit "index indication" at the top
and click on any patent
and, when the patent appears, 
hit the pink "DETAIL" at the top of the page to see a translated patent, 
or hit "JAPANESE" to see the original.

This "Detail" is what returns a blank page in Firefox 4.  With Firefox 3, an elaborate screen of claims, details, drawings, etc. in English is returned.
(Reporter)

Comment 12

7 years ago
Your attachment shows you stopped at the first page of a patent, which is basically brief "stored abstracts" from a simple library - Pressing the "DETAIL" button launches the "machine translation" giving various sections, while the "JAPANESE" brings up an image of the original patent.
Yes, I did press DETAIL, which got me to this URL:
http://www4.ipdl.inpit.go.jp/Tokujitu/PAJdetail.ipdl?N0000=60&N0120=01&N2001=2&N3001=2010-110360
This document is mostly ok. We render it as you can see from the
frameset border.  Both frames are blank, the content of the
first one is the one I attached.
http://www4.ipdl.inpit.go.jp/Tokujitu/tjswhen.ipdl?N0000=518&N0005=SFAOitNrYbYXeDrei2H2&N0500=4JPA%20422110360%20%20%20%20%20%20%20&N0510=3CwNyHYYA5H2KNG018lb&N0501=000100080008&N0502=1&N0201=0&N0504=2&N0002=0&N0001=32&N0700=0&N0701=0&N0702=0&N0703=1
The second frame contains nothing but <INPUT TYPE="hidden">
The <INPUT>s are <INPUT TYPE="hidden"> so this is a dupe of bug 607573.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Whiteboard: INVALID?
Duplicate of bug: 607573
You need to log in before you can comment on or make changes to this bug.