Closed Bug 610181 Opened 9 years ago Closed 7 years ago

browser_522545.js | No history entries still sets currentURI to about:blank - Got http://example.com/, expected about:blank

Categories

(Firefox :: Session Restore, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: robert.strong.bugs, Unassigned)

References

Details

(Keywords: intermittent-failure)

Rev3 MacOSX Leopard 10.5.8 mozilla-central opt test mochitest-other on 2010/11/07 00:17:20

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1289114240.1289115255.19931.gz

TEST-PASS | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | Address bar's value correctly updated
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | No history entries still sets currentURI to about:blank - Got http://example.com/, expected about:blank
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | userTypedValue was correctly restored - Got null, expected example.org
TEST-PASS | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | userTypeClear restored as expected
TEST-PASS | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | Address bar's value correctly restored
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | Address bar's value correctly updated - Got http://example.com/, expected example.org
Mass marking whiteboard:[orange] bugs WFM (to clean up TBPL bug suggestions) that:
* Haven't changed in > 6months
* Whose whiteboard contains none of the strings: {disabled,marked,random,fuzzy,todo,fails,failing,annotated,leave open,time-bomb}
* Passed a (quick) manual inspection of bug summary/whiteboard to ensure they weren't a false positive.

I've also gone through and searched for cases where the whiteboard wasn't labelled correctly after test disabling, by using attachment description & basic comment searches. However if the test for which this bug was about has in fact been disabled/annotated/..., please accept my apologies & reopen/mark the whiteboard appropriately so this doesn't get re-closed in the future (and please ping me via IRC or email so I can try to tweak the saved searches to avoid more edge cases).

Sorry for the spam! Filter on: #FFA500
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.