in the dialog box for file path to save a downloaded file, cmd+d don't set the path to the desktop, instead the bookmark window appears at the back of the dialog box

RESOLVED DUPLICATE of bug 431544

Status

()

Firefox
Keyboard Navigation
RESOLVED DUPLICATE of bug 431544
8 years ago
7 years ago

People

(Reporter: emmanuelpoirier, Unassigned)

Tracking

3.6 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; fr; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; fr; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12

Hi

Basically, the dialog box to choose where to save the file don't get the focus automatically and thus the keyboard event (cmd+d) is sent to firefox who then display the bookmark dialog box. Bug there since at least 3 revisions.

Reproducible: Always

Steps to Reproduce:
1.choose a file to download
2.once the dialog box to choose where to save has poped up, push cmd+d
3.
Actual Results:  
the path isn't changed (no desktop selected), the bookmark dialog pops up in the background

Expected Results:  
the dialog box get the focus, the path is set to the desktop

default theme used but plenty of adds-on installed, if you want more info, please contact me
(Reporter)

Updated

8 years ago
Summary: when on the dialog box to choose file path to save the download file, cmd+d don't set the path to the desktop, instead the bookmark window appears on the back of the dialog box → when in the dialog box to choose file path to save a downloaded file, cmd+d don't set the path to the desktop, instead the bookmark window appears on the back of the dialog box
(Reporter)

Updated

8 years ago
Version: unspecified → 3.6 Branch

Comment 1

8 years ago
User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13

I'd like to second this problem and add some insight. The behavior of this bug is dependent on whether the user hits "enter" on their keyboard or clicks with their mouse when dismissing the first prompt (see steps below).

Reproducible: Always

Steps to Reproduce:
- Preferences set to "Show the Downloads window when downloading a file" and "Always ask me where to save files"
- Clicking on a link that results in a file download prompts the user to select either open or save for the file in question (expected).
- Hitting enter or return on the keyboard (executing the default button "ok" to save the file) creates a File Dialog, but the browser takes focus (unexpected). However if you click the "ok" button with the mouse the File Dialog is created and has focus (expected).

The problem is that many users of OS X use the system-wide shortcut, command + d, to switch to the desktop in File Dialogs, however when the inconsistency above occurs hitting command + d results in Firefox creating a new bookmark. Visually the File Dialog remains on top of the browser, but focus is on the browser. 

Expected Results: I would expect that the behavior would be consistent whether or not the user was using a mouse or a keyboard.

Comment 2

7 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13

Agree with above.  As a more frustrating variant, if one uses Cmd-Shift-D in the file dialog (also typically switches dialog to Desktop directory), this falls through to the browser as Bookmark All Tabs.  The dialog generated in response to this command appears along with the Save File dialog, and neither responds to a click on the "ok" or "cancel" buttons, nor to keyboard shortcuts such as Enter, Cmd-., Esc.  The only option I've found thus far is to kill Firefox externally.
(Reporter)

Comment 3

7 years ago
Hi everybody,

has somebody found out where in the firefox code, the file dialog box and the shortcuts are dealt with so we can troubleshoot the issue at its roots?

Thanks for your commitment to this resolution.

Regards

E.
(Reporter)

Updated

7 years ago
Summary: when in the dialog box to choose file path to save a downloaded file, cmd+d don't set the path to the desktop, instead the bookmark window appears on the back of the dialog box → in the dialog box for file path to save a downloaded file, cmd+d don't set the path to the desktop, instead the bookmark window appears at the back of the dialog box

Comment 4

7 years ago
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b13pre) Gecko/20110316 Firefox/4.0b13pre

This bug is still semi prevalent on a current nightly of FF4.

Trying to reproduce the steps in comment 1 does not work well; If focus is retained or not seems to be random at best. Sometimes clicking the button works as expected, (download location selector has focus), but sometimes, randomly, unexpectedly (browser window retains focus). Hitting "enter" has the same/similar results, some attempts work fine, others show this bug.

This behavior is noticed in safe mode, ie, with no extensions loaded, however I have not tried on a clean profile yet.

Anyone have any other ideas to try for narrowing down this bug? I will admit to being new to bugzilla, so please be aware of this fact.

J
This is basically bug 431544.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 431544
You need to log in before you can comment on or make changes to this bug.