Closed Bug 610356 Opened 12 years ago Closed 10 years ago

Bookmarks and History list can't be accessed via the arrow keys

Categories

(Firefox for Android Graveyard :: General, defect)

Other
Other
defect
Not set
minor

Tracking

(fennec+)

RESOLVED WORKSFORME
Tracking Status
fennec + ---

People

(Reporter: anamaria.moldovan, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101104 Firefox/4.0b8pre
Build Identifier: Mozilla /5.0 (Android;Linux armv7l;rv:2.0b8pre) Gecko/20101108 Firefox/4.0b8pre Fennec /4.0b3pre

This test case requires a device with a hard keyboard.
Devices: Motorola DROID 2

    

Reproducible: Always

Steps to Reproduce:
1. Ensure you have website url data stored by typing the urls into the location bar and visiting the sites. Bookmark some of the webpages.
2. Tap in the location bar
3. Select Bookmarks or History
4. Press the down arrow to access the drop down menu (fills the whole screen) of recently visited sites or of the bookmarked sites
    
Actual Results:  
One can see the "History" or "Bookmarks" list, but when pressing the down arrow from the keyboard to access the drop down menu, the auto-complete list that appears is the one from "All Pages". 
Basically, even though Bookmarks / History was selected the focus still remains on "All Pages".

Ensure that the Auto-complete list appears and that the selected site loads in the browser.



Expected Results:  
The Auto-complete list for Bookmarks or History should appear.
Looks like the arrow-down key is still attached to the "All pages" list and not the "History" or "Bookmark" lists
Assignee: nobody → 21
tracking-fennec: --- → 2.0+
tracking-fennec: 2.0+ → 2.0-
Whiteboard: [fennec-4.1?]
Summary: Access the Location bar entered locations list for Bookmarks and History → Bookmarks and History list can't be accessed via the arrow keys
tracking-fennec: - → 7+
Whiteboard: [fennec-4.1?]
tracking-fennec: 7+ → +
Assignee: 21 → nobody
Assignee: nobody → snorp
It looks like the 'all pages' list uses some scrolling stuff that the others don't have.  It would probably be best if some UI wizard went after this one...
Assignee: snorp → nobody
Product: Fennec → Fennec Native
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WORKSFORME
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.