Browser freezes appending to <select>

RESOLVED DUPLICATE of bug 607856

Status

()

RESOLVED DUPLICATE of bug 607856
8 years ago
8 years ago

People

(Reporter: alistair.vining, Unassigned)

Tracking

({testcase})

Trunk
x86
Windows XP
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Created attachment 488872 [details]
Reduced testcase

(Component / summary is just a guess)

Mozilla/5.0 (Windows NT 5.1; rv:2.0b8pre) Gecko/20101108 Firefox/4.0b8pre

Visiting the linked URL or the reduced testcase in a current nightly build pegs the CPU at 100% for 3 minutes, whereas IE8 takes < 1 sec.

This is a slow PC, but it's not normally *that* slow, and I seem to be experiencing > 20 second hangs all over the web at the moment which may be related.

As far as I can see (I'm not a jQuery guru) it loops over about 190 <option> elements inside one <select> and appends them to another <select>.

Notes: non-SSE2 processor, therefore no methodjit.  No accelerated gfx.  Extensions disabled.
Tested in 3.6 and trunk, no hangs observed.

Does this happen in 3.6 too?
Keywords: testcase
> Notes: non-SSE2 processor, therefore no methodjit.

Mounir, do you see the problem if you disable methodjit?

If so, sounds like bug 607856 to me.
Indeed, I wasn't careful enough and it doesn't work with methodjit disabled.

Marking as a duplicate of bug 607856 for the moment.
Alistair, feel free to reopen if this isn't fixed when bug 607856 is fixed.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 607856
You need to log in before you can comment on or make changes to this bug.