Closed Bug 610580 Opened 9 years ago Closed 9 years ago

TMFLAGS=abort no longer works

Categories

(Core :: JavaScript Engine, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: bzbarsky, Assigned: billm)

References

Details

(Keywords: regression, Whiteboard: fixed-in-tracemonkey)

Attachments

(1 file)

Bug 580468 changed finishAbort from using LC_TMAbort to using LC_TMMinimal.  Was this on purpose?  If so, can we please remove the incorrect documentation?  But I'd prefer it if we just restored the old behavior, since "minimal" outputs a whole bunch of info that's not really needed if you just want to see where traces are being aborted....
(In reply to comment #0)
> Bug 580468 changed finishAbort from using LC_TMAbort to using LC_TMMinimal. 
> Was this on purpose?  If so, can we please remove the incorrect documentation? 
> But I'd prefer it if we just restored the old behavior, since "minimal" outputs
> a whole bunch of info that's not really needed if you just want to see where
> traces are being aborted....

Sorry, I should have been more careful when messing with the debug printfs. I do like that it appears for minimal, so it might make sense to have it appear in both cases.
I'd be ok with that, though setting TMFLAGS=abort,minimal seems easy enough... ;)
Attached patch fixSplinter Review
This should fix it.

As an aside, would it be okay to change the definition of debug_only_printf as follows? From
    #define debug_only_printf(mask, fmt, ...) ...
to
    #define debug_only_printf(mask, ...) ...

That way I think we could get rid of debug_only_print0. It seems like this should work on all compilers, but I also have to believe that there's a reason why both macros are there.
Assignee: general → wmccloskey
Status: NEW → ASSIGNED
Attachment #489566 - Flags: review?(bzbarsky)
Comment on attachment 489566 [details] [diff] [review]
fix

r=me; I have no idea why print0 is around...
Attachment #489566 - Flags: review?(bzbarsky) → review+
(In reply to comment #4)
> 
> r=me; I have no idea why print0 is around...

GCC warns if you have a variadic macro ('...') and there are zero args.  Maybe Bill's change will fix that.
http://hg.mozilla.org/mozilla-central/rev/20ffa99ddd80
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.