[Find in Page]Search should not be performed on link anchors.

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
8 years ago
7 years ago

People

(Reporter: anamaria.moldovan, Unassigned)

Tracking

Trunk
ARM
Android

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101108 Firefox/4.0b8pre
Build Identifier: Mozilla /5.0 (Android;Linux armv7l;rv:2.0b8pre) Gecko/20101108 Firefox/4.0b8pre Fennec /4.0b3pre

Strings that are not in the page content (visible to the eye) are being found.

Device: Motorola DROID 2

Reproducible: Always

Steps to Reproduce:
1. Visit www.mozilla.org
2. Bring up the “Find In Page” toolbar by tapping on the page favicon and then “Find in page”.
3. Enter string “facebook” in the search field.
4. Use arrow-buttons to navigate through your results

Actual Results:  
One match is found (see attached screenshot)


Expected Results:  
Since the destination anchor of the Facebook link is not visible to the eye, there should be no matches for this string.
(Reporter)

Comment 1

8 years ago
Created attachment 489115 [details]
Find in page
Same behavior happens on desktop firefox. Looking at the page source, the text looks like findable text to me.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 3

8 years ago
Isn't the idea of "Find in page" to search for certain strings in the page content? Since there is no "facebook" string, but only the icon in the page content why should it be highlighted?

On Firefox Desktop the matched string is not displayed over the icon. (see attached screenshot)
(Reporter)

Comment 4

8 years ago
Created attachment 489425 [details]
Firefox Desktop
(Reporter)

Comment 5

8 years ago
On about:firstrun or www.softvision.ro there are the icons for Twitter and Facebook. When searching for Facebook no results are found.
From the mozilla.org page source:

<li id="home-news-facebook"><a href="http://www.facebook.com/Firefox?v=wall">Firefox on Facebook</a></li>

"Firefox on Facebook" is text in the page. Therefore, Find-in-Page can find it.

From about:firstrun page source:

<li id="follow-facebook"><a href="http://www.facebook.com/firefoxformobile"><img src="chrome://browser/content/firstrun/facebook.png" height="41" width="42" /></a>

There is no text
(Reporter)

Updated

8 years ago
OS: Other → Android
Hardware: Other → ARM
You need to log in before you can comment on or make changes to this bug.