If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Add-on dialog is modal and blocks Firefox

RESOLVED DUPLICATE of bug 511529

Status

()

Toolkit
Add-ons Manager
RESOLVED DUPLICATE of bug 511529
7 years ago
7 years ago

People

(Reporter: neil, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dupeme])

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12 (.NET CLR 3.5.30729)

Whenever Firefox starts and an add-on has an update it would like me to install, the dialog blocks Firefox from starting.

This isn't just stupid (given you just get a task bar popup when Firefox is already running) but it is really REALLY annoying because a lot of the time Firefox is being started by external means, e.g. a url from a website or an email

What happens is you get an error message and Firefox and your link is not started.

Please make this modeless, or provide a default means of not providing this daft modal dialog until after Firefox has started.

Thanks.


Reproducible: Always

Actual Results:  
Firefox doesn't start. Your link is not navigated to.

Expected Results:  
For Firefox to start as expected.

Comment 1

7 years ago
Quite sure this has been resolved for Firefox 4.
Component: General → Add-ons Manager
Product: Firefox → Toolkit
QA Contact: general → add-ons.manager
Whiteboard: [dupeme]
Yes, this has been fixed with the refactoring, which was part of bug 511529.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 511529
You need to log in before you can comment on or make changes to this bug.