[MF]No Way To Change Print Range

VERIFIED FIXED in mozilla0.9.1

Status

()

P3
normal
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: brian, Assigned: rods)

Tracking

Trunk
mozilla0.9.1
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
In the latest builds, I cannot select a range of pages to print or print from
selected text.  I really miss these features.  I'm filing this as a bug because
I believe these need to be there.  Thanks!  Keep up the good work!
(Reporter)

Comment 1

18 years ago
Still an issue in 2000120220.
(Reporter)

Comment 2

18 years ago
Still Issue in 2000120920

Comment 3

18 years ago
Looks like dcone is looking into this.

*** This bug has been marked as a duplicate of 62561 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

18 years ago
Wait.. how can mine 61075 be a dupe of 62561 when mine was reported first and
neither have had any action and both are assigned to the same person?  Shouldn't
it be the other way around?  Sorry, it just makes my record look bad when I have
a bunch of dupes.

Comment 5

18 years ago
let's keep your record clean :). reopening tihs one and marking 62561 as a dup 
of this one..
Status: RESOLVED → UNCONFIRMED
OS: other → All
Resolution: DUPLICATE → ---

Comment 6

18 years ago
confirming bug (sorry for the spam)
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 7

18 years ago
*** Bug 62561 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 8

18 years ago
Thanks Fabian.  I really appreciate this.  I've made a few mistakes in the past
about dupes, but trying to see how long I can be dupe free. :)

Comment 9

18 years ago
Doesn't make a difference to me.. The only thing I saw was that the person who
is supposed to do it filed the bug, so I thought he would probably like to keep
his own bug. Anyway I understand you want to keep your record clean but Bugzilla
is a bug database, not a game to have the best record as possible, nobody will
blame anyone because they file dups.
Also dcone's bug was NEW and this one was UNCO.
Fabian the humble Bugzilla servitor.
(Reporter)

Comment 10

18 years ago
Ok, I didn't realize that.  I'm glad to hear no one blames anyone bout dupes.  I
always felt like I wasted someone's time for filing a dupe.  You can do whatever
you like.  Just as long as it get fixed. :)  Thanks!  Keep up the good work u guys.
Marking mozilla0.8.
Target Milestone: --- → mozilla0.8

Updated

18 years ago
Blocks: 64841
(Assignee)

Comment 12

18 years ago
I am ready for reviews
Assignee: dcone → rods
Whiteboard: checkin by 1/22 - 1/24, I am ready for reviews
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Summary: No Way To Change Print Range → [MF]No Way To Change Print Range
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 13

18 years ago
fixed
(Reporter)

Comment 14

18 years ago
In Build 2001012904

Whenever I go to the print dialog, it asks if it should print all 1001 pages.  I
know this is minor, but it should really be cleaned up before mozilla0.7 or
mozilla0.8 for sure.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 15

18 years ago
spam : changing qa to sujay (new qa contact for Printing)
QA Contact: shrir → sujay
(Assignee)

Comment 16

18 years ago
Could you attach a screen shot of the dialog, this sounds way bizzare
Status: REOPENED → ASSIGNED
(Reporter)

Comment 17

18 years ago
Created attachment 24185 [details]
Screen Shot :)
(Assignee)

Comment 18

18 years ago
At this moment, I am at a complete loss as to what would cause this..... It's 
their dialog, and their code manipulating it. Truly bizzare, give Bill G. a 
call.
(Reporter)

Comment 19

18 years ago
I'm afraid I don't know who Bill G is.  
(Assignee)

Comment 20

18 years ago
As in Bill Gates....
Rod: We are not clearing out the struct that we pass to ::PrintDlg.
Maybe we should clear out the prntdlg struct before setting the values in it?


NS_IMETHODIMP nsDeviceContextSpecFactoryWin :: CreateDeviceContextSpec

...

 PRINTDLG  prntdlg;

+ memset(&printdlg, 0, sizeof(PRINTDLG);

  prntdlg.lStructSize = sizeof(prntdlg);
  prntdlg.hwndOwner = NULL;               /
  prntdlg.hDevMode = NULL;
  prntdlg.hDevNames = NULL;
  prntdlg.hDC = NULL;
  prntdlg.Flags = PD_ALLPAGES | PD_RETURNIC

Updated

18 years ago
Whiteboard: checkin by 1/22 - 1/24, I am ready for reviews

Comment 22

18 years ago
This (printing page range) was working for me (after the FIXED), but now it
doesn't anymore (2001-02-05-21/Linux). I opend bug 67537 for this problem.
(Assignee)

Comment 23

18 years ago
fxied
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 24

18 years ago
Still Issue (print all 1001 pages) on 2001020820 Win32 Build.  Can't speak for
the other builds.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 25

18 years ago
Index: src/windows/nsDeviceContextSpecFactoryW.cpp
===================================================================
RCS file: /cvsroot/mozilla/gfx/src/windows/nsDeviceContextSpecFactoryW.cpp,v
retrieving revision 3.12
diff -u -r3.12 nsDeviceContextSpecFactoryW.cpp
--- nsDeviceContextSpecFactoryW.cpp     2001/02/06 23:03:06     3.12
+++ nsDeviceContextSpecFactoryW.cpp     2001/02/13 23:27:02
@@ -155,10 +155,10 @@
     printService->GetHowToEnableFrameUI(&howToEnableFrameUI);
   }

-  prntdlg.nFromPage           = 1;
-  prntdlg.nToPage             = 1;
-  prntdlg.nMinPage            = 0;
-  prntdlg.nMaxPage            = 1000;
+  prntdlg.nFromPage           = 0xFFFF;
+  prntdlg.nToPage             = 0xFFFF;
+  prntdlg.nMinPage            = 1;
+  prntdlg.nMaxPage            = 0xFFFF;
   prntdlg.nCopies             = 1;
   prntdlg.hInstance           = hInstance;
   prntdlg.lCustData           = (DWORD)howToEnableFrameUI;
@@ -171,7 +171,7 @@


   if(PR_TRUE == aQuiet){
-    prntdlg.Flags = PD_RETURNDEFAULT;
+    prntdlg.Flags = PD_ALLPAGES | PD_RETURNDEFAULT;
   }

   BOOL res = ::PrintDlg(&prntdlg);
Status: REOPENED → ASSIGNED
Keywords: patch
Target Milestone: mozilla0.8 → mozilla0.9.1

Comment 26

18 years ago
Cool. sr=attinasi

Comment 27

18 years ago
r=dcone
(Assignee)

Comment 28

18 years ago
I couldn't find any documentation explaining on this specifically (classic 
Microsoft)

But it appears if you set nMinPage to 0, and then nFromPage, nTomPage, & 
nMaxPage to 0xFFFF the dialog behaves the way you want it to for "All Pages" and 
"Page Range" 

Plus, it appears you need to pre-set the flags to both "PD_ALLPAGES | 
PD_RETURNDEFAULT" in order for the dialog to not appear and have the 
"::PrintDlg(&prntdlg);" call return.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 29

18 years ago
Brian, is this working for you now? please mark verified-fixed...thanks!
(Reporter)

Comment 30

18 years ago
Yep, works great. :)  Doesn't display total number of pages though.  Maybe I'll
open another bug requesting that.
Status: RESOLVED → VERIFIED
(Assignee)

Comment 31

18 years ago
You can open a bug for that, but it will be futured or marked invalid. It's 
a chicken and egg problem. You can't display the number of pages without laying 
the document out. You can't lay the document out until you know what driver you 
are using or the desired page size (which happens to be on the same dialog), 
which is needed so you know how big the page will etc.

IE doesn't do it and in fact I would imagine that none of the browsers do it for 
that very same reason. Word processors can do it because the document you are 
typing in already has a formated page size. In a browser, what you look at is 
laid out completely different from how it goes to the printer.
You need to log in before you can comment on or make changes to this bug.