Intermittent failure in xpcshell/test_bootstrap.js and xpcshell-unpack/test_bootstrap.js | -1 == 2

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
9 years ago
7 years ago

People

(Reporter: philor, Assigned: mossop)

Tracking

({intermittent-failure})

Trunk
x86
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

9 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1289431837.1289433000.19200.gz&fulltext=1#err0
Rev3 Fedora 12 mozilla-central opt test xpcshell on 2010/11/10 15:30:37
s: talos-r3-fed-011

TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/mozilla-central_fedora_test-xpcshell/build/xpcshell/tests/toolkit/mozapps/extensions/test/xpcshell/test_bootstrap.js | test failed (with xpcshell return code: 0), see following log:
TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/mozilla-central_fedora_test-xpcshell/build/xpcshell/tests/toolkit/mozapps/extensions/test/xpcshell/test_bootstrap.js | -1 == 2 - See following stack:
TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/mozilla-central_fedora_test-xpcshell/build/xpcshell/tests/toolkit/mozapps/extensions/test/xpcshell-unpack/test_bootstrap.js | test failed (with xpcshell return code: 0), see following log:
TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/mozilla-central_fedora_test-xpcshell/build/xpcshell/tests/toolkit/mozapps/extensions/test/xpcshell-unpack/test_bootstrap.js | -1 == 2 - See following stack:

The juicy part of the log is

TEST-PASS | /home/cltbld/talos-slave/mozilla-central_fedora_test-xpcshell/build/xpcshell/tests/toolkit/mozapps/extensions/test/xpcshell/test_bootstrap.js | [anonymous : 983] true == true
*** LOG addons.xpi: Calling bootstrap method shutdown on bootstrap1@tests.mozilla.org version 1.0
*** LOG addons.xpi: shutdown
*** LOG addons.xpi: startup
*** LOG addons.xpi: checkForChanges
*** LOG addons.xpi: No changes found
*** LOG addons.xpi: Add-ons list is missing, recreating
*** LOG addons.xpi: Writing add-ons list
*** LOG addons.xpi: Opening database
*** LOG addons.xpi: Loading bootstrap scope from /tmp/tmp0XJP5m/extensions/bootstrap1@tests.mozilla.org
*** LOG addons.xpi: Calling bootstrap method startup on bootstrap1@tests.mozilla.org version 1.0
TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/mozilla-central_fedora_test-xpcshell/build/xpcshell/tests/toolkit/mozapps/extensions/test/xpcshell/test_bootstrap.js | -1 == 2 - See following stack:
JS frame :: /home/cltbld/talos-slave/mozilla-central_fedora_test-xpcshell/build/xpcshell/head.js :: do_throw :: line 420
JS frame :: /home/cltbld/talos-slave/mozilla-central_fedora_test-xpcshell/build/xpcshell/head.js :: do_check_eq :: line 472
JS frame :: /home/cltbld/talos-slave/mozilla-central_fedora_test-xpcshell/build/xpcshell/tests/toolkit/mozapps/extensions/test/xpcshell/test_bootstrap.js :: anonymous :: line 1005
JS frame :: resource://gre/modules/AddonManager.jsm :: safeCall :: line 45
JS frame :: resource://gre/modules/AddonManager.jsm :: anonymous :: line 682
JS frame :: resource://gre/modules/XPIProvider.jsm :: anonymous :: line 2480
JS frame :: resource://gre/modules/XPIProvider.jsm :: anonymous :: line 4227
JS frame :: resource://gre/modules/XPIProvider.jsm :: completeAddon :: line 3250
JS frame :: resource://gre/modules/AddonRepository.jsm :: anonymous :: line 438
JS frame :: resource://gre/modules/XPIProvider.jsm :: anonymous :: line 3254
JS frame :: resource://gre/modules/XPIProvider.jsm :: anonymous :: line 4099
JS frame :: resource://gre/modules/XPIProvider.jsm :: anonymous :: line 4098
TEST-INFO | (xpcshell/head.js) | exiting test
*** WARN addons.manager: Exception calling callback: 2147500036
Reporter

Comment 1

9 years ago
Possibly related, from the same run, bug 611178.
Assignee

Updated

9 years ago
Blocks: 611178
This was caused by the build machine having its clock 50 minutes fast.

Since bug 594058 landed we use the newest modification time of all files in an extension to determine its install date and and then we detect changes to the extension by comparing its install date across startups. Unfortunately there is a minor problem with that in that if files are modified but there are other files with their dates in the future then no change is detected. In these failures some of the files were in the future and so any changes the test made were ignored.
Blocks: 594058
No longer blocks: 611178
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Posted patch patch rev 1Splinter Review
The problem here is that the test code for setting the modification time of an extension only sets the directory and install.rdf. Anything that has more files than that won't get set right. This recursively sets the modification time of all files in the extension.
Assignee: nobody → dtownsend
Status: NEW → ASSIGNED
Attachment #516720 - Flags: review?(robert.bugzilla)
Landed: http://hg.mozilla.org/mozilla-central/rev/acdd32f12199
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.