Java applet public method isn't called from JavaScript.

RESOLVED FIXED

Status

()

Core
Plug-ins
--
major
RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: Stephen Bannasch, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_4; en-us) AppleWebKit/533.18.1 (KHTML, like Gecko) Version/5.0.2 Safari/533.18.5
Build Identifier: Minefield 4.0b8pre

The page was setup to show a work-around for Bug 606737 but when tested on Minefield 4.0b8pre the JavaScript call to the applet public method setupJSObject() is never received by the applet.

The page has a description of the context for Bug 606737, how the workaround operates and also displays the Java code that makes up the applet.

If the bug is NOT present the following will be displayed (and is displayed on all browsewrs ecept for FireFox 4):

  If successful the Java console will display something like: WINDOW IS: [object DOMWindow] 
  or [object Window] and the result should be displayed here in green text: [object DOMWindow]

The last phrase in that text " [object DOMWindow]" is displayed in GREEN and indicates the Applet successfully communicated the result of it's attempt to execute JSObject win = JSObject.getWindow(this)

The following should be printed at end of Java console:

calling: jsListener.displayJSObject('[object DOMWindow]');

Reproducible: Always

Steps to Reproduce:
Open http://jnlp.dev.concord.org/test-japplet2.html

Actual Results:  
2. Look in Java Console log and you won't see a statement like this:

  calling: jsListener.displayJSObject('[object DOMWindow]');

3. And the result of executing that statement won't appear in the browser window.

Expected Results:  
see a statement like this in Java Console log:

  calling: jsListener.displayJSObject('[object DOMWindow]');

And see the result of executing that statement in the browser window.
(Reporter)

Updated

8 years ago
Version: unspecified → Trunk

Comment 1

7 years ago
This is fixed in 3.6.13, it seems
Component: General → Plug-ins
Product: Firefox → Core
QA Contact: general → plugins
I can't reproduce this bug in today's Minefield nightly (testing on OS
X 10.6.5).  It might have gotten fixed ... though I don't know by
what.

> This is fixed in 3.6.13, it seems

This bug was reported on the trunk (aka FF4, Minefield), not in FF
3.6.X (aka the 1.9.2 branch).
(Reporter)

Comment 3

7 years ago
I also cannot reproduce the bug on Minefield 4.0b10pre (2011-01-14) on Mac OS X 10.6.5.

The bug also does not appear on the latest version of 4.0b8 I have installed on my computer.

This is very good!

it is frustrating that the About FireFox box doesn't provide a version number with more resolution that 4.0b8 -- this copy I have been running has been updated numerous times and one of those changes fixed this problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.