Closed Bug 61126 Opened 22 years ago Closed 22 years ago

Non-system charsets in document titles map to sys default characters

Categories

(Core :: Internationalization, enhancement, P3)

x86
Windows NT
enhancement

Tracking

()

VERIFIED DUPLICATE of bug 9449

People

(Reporter: decoy, Assigned: danm.moz)

References

()

Details

(Keywords: helpwanted, intl, Whiteboard: [ie5p])

Even in documents with an encoding surpassing the system character set (like
utf-8), the browser attempts direct rendering of the document title into the
title bar. Under win32, foreign characters are converted into system default
character. In case of completely unreadable document titles, the result is
unaesthetic (a long series of question marks, for instance) and uninformative.
At the same time the GUI components used by the browser inside the window
content can render the title just fine. If it is not possible to use Mozilla's
own character rendering code to render the window caption, it would be advisable
to handle this situation like IE5.5 does - to show the document URI instead.
updating component.
Assignee: asa → nhotta
Component: Browser-General → Internationalization
QA Contact: doronr → teruko
Status: UNCONFIRMED → NEW
Ever confirmed: true
fwiw. On windows2000, ie5.5 is always able to render chineese characters into 
the titlebar even though mozilla can't.  I suspect we're generally messing up.  
But I am not sure how.

Hrm. Reporter: what fonts are you using for window title? [I'm using Tahoma]

In regional options [general tab], I have all languages in the list in 
"Language settings for the system" selected. [Also in the Advanced dialog].

What we have is ok, so i'm going to mark this as an Enhancement request.
Severity: minor → enhancement
Keywords: helpwanted
Whiteboard: [ie5p]
Reassign to trudelle, please reassign to the owner of the windows title bug.
Assignee: nhotta → trudelle
->danm
Assignee: trudelle → danm
Keywords: intl


*** This bug has been marked as a duplicate of 9449 ***
Status: NEW → RESOLVED
Closed: 22 years ago
Resolution: --- → DUPLICATE
Verified as dup.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.