Closed Bug 611519 Opened 9 years ago Closed 9 years ago

Firefox fails to work correctly with Ogg Vorbis Streams (Probably easy to fix!)

Categories

(Core :: Audio/Video, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 455165

People

(Reporter: drichards, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_4; en-us) AppleWebKit/533.18.1 (KHTML, like Gecko) Version/5.0.2 Safari/533.18.5
Build Identifier: 

This affects all platforms. If you tune into an Ogg Vorbis stream, ie from icecast, it will play correctly... until the metadata changes!

Why does this happen? Two reasons I'm fairly certain of. 

1) Firefox just thinks its getting a very large ogg file very slowly, it doesn't treat it like the stream that it is.

2) The way Ogg streaming works, is that it simply appears as a sequence of Ogg files, if the metadata were to never change, then it would just be one massive file. However the way metadata changes work, is that the current ogg gets some packets that say "end of the file" and then a new ogg file is started that includes the vorbis comment header packet and some other getting started data, and then the  stream continues onward.

Hope this helps.

Cheers,

David

ps. This is screwed up in exactly the same way on the current version of google chrome! Perhaps a specifically industrious individual could fix both cases! 

pps. It would be nice if firefox also supported OggFLAC streaming. That would please many audiophiles. I have not looked at the code, but if its set up correctly, the same code that decodes Ogg for vorbis and theora support can be used and then only the flac decoder portion would need to be added. I don't suspect this to be very difficult to add in general, it would just take some nice persons time that is all :]



Reproducible: Always

Steps to Reproduce:
1. Tune into an Ogg Vorbis Stream 
2. Wait for the metadata to change (such as when the song changes)
3. Frown and groan a little
Actual Results:  
The stream stopped playing and wont start again unless the tab is reloaded.

Expected Results:  
It should play the stream without ceasing. The software should also be aware in general that its playing a stream and not a file, so that it doesn't become a massive memory leak.

Ogg Vorbis is awesome, streaming Ogg Vorbis is awesome, and firefox should make it possible to tune in, turn on and drop out. errrr. . wait, I mean stay tuned and not drop out!
I am sorry that I submitted this bug report with safari on a mac. Please forgive me, I have five linux computers and just one mac labtop (for debugging mac only problems only). 

Also I will paypal atleast twenty usd to whomever fixes this.
Component: General → Video/Audio
Product: Firefox → Core
QA Contact: general → video.audio
One more note on safari however. Apple is too wussie to support vorbis and flac on there browser, even tho doing so would be minimal difficulty on there part and not eat into there profits whatsoever. But one thing that safari does get right, is MP3 streaming. If you use an html5 audio tag src'ed to an mp3 stream, the default control widget indicates that it is a "live stream". It would be nice to beat them at this game.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 455165
You need to log in before you can comment on or make changes to this bug.